Verdin iMX8MP Gstreamer issue with encoder and decoder

I am trying to run a gstreamer pipeline on the Verdin iMX8MP mounted on the Dahlia Carrier Board. However, when running the pipeline, I am coming up against the error “vpuenc_h264-0: Could not initialize supporting library”.

I built a custom Yocto image using the tdx-reference-multimedia-image and a few minor customizations.

The pipeline I am trying to run:

gst-launch-1.0 videotestsrc ! video/x-raw, format=I420, width=640, height=480 ! vpuenc_h264 ! filesink location=videotestsrc.mp4

I also tried other pipelines, including one suggested in another topic and was getting the same message for vpudec.

cat /etc/os-release
NAME=“TDX Wayland with XWayland”
VERSION=“6.1.0-devel-20221213050554+build.0 (kirkstone)”
PRETTY_NAME=“TDX Wayland with XWayland 6.1.0-devel-20221213050554+build.0 (kirkstone)”

cat /etc/issue
TDX Wayland with XWayland 6.1.0-devel-20221214012039+build.0 (kirkstone) \n \l

uname -a
Linux verdin-imx8mp-07331488 5.15.40-6.1.0-devel+git.b4f7c3c44d85 #1 SMP PREEMPT Tue Oct 11 15:25:52 UTC 2022 aarch64 aarch64 aarch64 GNU/Linux

Hi @dandresky,

I’ve never seen this issue before on my side (cc: @henrique.tx), but found some links that might be useful (one from NXP):

Can you please check if this is not related to your custom image? Could you please try one of our images?

Best Regards,

Hi @dandresky !

There was indeed some problem with Gstreamer and Verdin iMX8M Plus recently: Toradex System/Computer on Modules - Linux BSP Release, ELB-4699

I just installed the latest image available:

root@verdin-imx8mp-06849036:~# tdx-info

Software summary
Bootloader:               U-Boot
Kernel version:           5.15.77-6.1.0-devel+git.bbbc03a7f625 #1 SMP PREEMPT Wed Dec 7 16:40:51 UTC 2022
Kernel command line:      root=PARTUUID=c4ae3b6d-02 ro rootwait console=tty1 console=ttymxc2,115200 consoleblank=0 earlycon
Distro name:              NAME="TDX Wayland with XWayland"
Distro version:           VERSION_ID=6.1.0-devel-20221220-build.143
Hostname:                 verdin-imx8mp-06849036

Hardware info
HW model:                 Toradex Verdin iMX8M Plus WB on Verdin Development Board
Toradex version:          0058 V1.0B
Serial number:            06849036
Processor arch:           aarch64

And I could run your pipeline without issue. Could you please also test on your side?

On a side note, please see that the support for Verdin iMX8M Plus is still not complete on BSP 6:

Best regards,

Thanks @henrique.tx

I just tried the prebuilt images for both the 6.0 BSP (kirkstone) and 5.7 BSP (dunfell). I see the issue with 6.0 but 5.7 works as it should. Is there an issue I can follow that tracks progress for BSP 6.0 support on the Verdin board?

Hi @dandresky,

We have the issue tracker here: Toradex System/Computer on Modules - Linux BSP Release.
And also the roadmap that gets updated once we enable more features (in the link that @henrique.tx shared with you).

Best Regards,