Verdin iMX8MM: no HDMI output for 7inch screen

Hello. I have combination of:

I have flashed tdx-reference-multimedia-image and i have problems with displaying image on 7inch screen. It works - displays image - on my Dell U2414H monitor (though screen is greenish/pinkish but i can see demo, animations, text, etc., so i guess it is related to HDMI cable/standard?). But when i use the same HDMI cable to connect iMX8MMini+DevBoard+Adapter to 7 inch screen it doesnt show any image (other HDMI cable that works with different boards yields the same result - no video).

It works if i power LCD via PC USB hub, turn board on, let it initialize and then touch tip of USB-c cable (from PC USB hub) to case of USB connector (X33 / X66) or even RS232/USB-H (X51 / X53). Image shows up with corrent colours.
So my guess it has something to do with common electrical ground? All devices (my PC, screens, USB hub, dev board) are using one power sorce - same power strip.

dmesg related to screen:

dmesg | grep lt8
[    2.747251] lt8912 3-0048: "1024x600": 60 49000 1024 1029 1042 1312 600 602 605 622 0x48 0x5
[    2.751494] lt8912 3-0048: LT8912 ID: 12, b2

Another case: when i power LCD screen by connecting LCD screen via dev board USB - it works for a moment (i can sometimes see booting logs but then its all black again - backlight on). Usualy after powering up red led on dsi adapter blink → sometimes logs show up on screen, sometimes not → red led blinks again and screen stays black + backlight on.

I have another 7inch screen and it behaves the same.

Maybe someone had already encountered such problem before?
Is it related to electronics / jumpers configuration somehow? Or maybe it has something to do with driver/ initialization/ configuration?


which BSP version are you using?
keep in mind not all resolutions are supported.

Best Regards,


Sorry for the late reply :slight_smile:

BSP version? I tried to build it on branch dunfell-5.x.y and currently im using tag 5.6.0. Not if sure that is the BSP version.
I use tdx-reference-multimedia-image for bitbake.

I can’t make 1024x600 (native resolution) work on imx8mm + dsi-hdmi adapter.
It works in 1024x768 resolution when i edit /etx/xdg/weston/weston.ini
If i set it to 1920x1080 it works… randomly. 1/2 time it works, another 1/2 backlight is on but no demo shows up after boot.

1024x600 resolution works out of the box for imx8mp and native hdmi output - no need to change or configure anything.

It seems it is the same problem: No HDMI Output using new displays/monitors
Screen stops working on resolutions lower than 1024x600

Hello TomT,

it seems to be a limitation of the DSI to HDMI converter.

Best Regards,

Matthias Gohlke