No HDMI Output using new displays/monitors

Hello,

I’m trying to get video output from DSI to HDMI adapter, but I’m not able to make it work.
I am testing with 3 different displays:

  • Standard HDMI 5" display 800x480 (link text)
  • Standard HDMI 7" display 1024x600 (link text)
  • Computer Monitor 24" 1920x1080 LG Flatron M2380A (link text)

And they have the same behaviour:

  • They show correct video output when I run Toradex Easy Installer, booting on recovery mode.
  • After I install an image (I’ve tried TorizonCore with evaluation containers v5.1.0 and QT for Device Creation Demo Image v5.15.1) there is no more video output.

After doing a lot of tests, I’ve connect to an older HDMI television (more than 10 years old), and it works correctly without any problem.
It seems like there is a failure when device negotiates HDMI resolution/refresh rate in my displays.

It seems to be the same problem posted here: link text
and here: link text

I’ve tried setenv tdxargs video=… / saveenv / boot solution, but I could not make it work.
The only way I get image was using 1920x1080 on 5" display, and it is an invalid resolution for it, so I see very poor quality image because it is downsampled.

Do you have any suggestions?
Thank you very much!

I forgot to mention that all the displays I used work correctly when I connect them to my desktop PC or connected to another embedded PC system, both running Windows 10. And the resolution is automaticaly set correct on each case.
The cables used were alway the same, working correctly when displays are connected to windows 10 computers, or connected to Verdin board running Toradex Easy Installer.

Greetings @apanelli,

By default TorizonCore should be running some containers, one of them being a weston container could you try obtaining the logs from this container for 2 cases. The case with one of the HDMIs that doesn’t work and then the case with the HDMI that does work. That way we can compare the two cases

Also something that might be worth trying is forcing a specific resolution for HDMI via weston in the ini file.

Best Regards,
Jeremias

Hi Jeremias,
I’ve tried different values by setting ‘tdxargs video…’ at U-boot and also removing it, with both screens (5 inch display that is not working and 32 inch TV that works ok).
The weston container logs are attached. The same behaviour occurs if I clear ‘tdxargs’ and force resolution via ‘weston.ini’.
I’m not sure about HDMI versions (1.3, 2.0, etc.), could it be a compatibility version issue?
link text

Best regards,
Alejandro

Have you installed a proper DeviceTree overlay ?

I’ve set fdt_overlays=verdin-imx8mm_lt8912_overlay.dtbo in overlays.txt. I’m not sure if it is required to do any other configuration.

Based on your logs, I believe I know the issue here.

So it seems on lower resolutions their is no display output. I checked internally and it seems there’s a known issue where on lower resolutions a lower pixel clock value is required. Lower than the minimal value supported by the DSI to HDMI adapter we use.

Currently a workaround would be to either force a higher resolution (as you’ve done). Or artificially require a higher pixel clock by increasing the blanking timing values. Though of course these aren’t full solutions.

Let me bring your case up and see if I can get an update/movement on this known issue.

Best Regards,
Jeremias

Hi Jeremias,
Could you find something about this known issue?
We need to use more development stations using HDMI displays, and we are not able to use them because of this issue.
Thanks in advance!

Best regards,
Alejandro

Hi Alejandro,

After further discussion I don’t believe this is an issue we’ll be able to solve. It really seems like a hardware limitation of the DSI to HDMI bridge we use that only allows higher resolution displays to work.

Our only suggestion is to stick with higher resolution displays.

Best Regards,
Jeremias