Imx8x with Viola. How to put latest TorizonOS Version without UART-TTL


U-Boot 2018.03-toradex_imx_v2018.03_4.14.78_1.0.0_ga-bringup+gd06de417f2 (Jan 01 1970 - 00:00:00 +0000)

CPU:   Freescale i.MX8QXP revB A35 at 1200 MHz at 45C
DRAM:  2 GiB
PMIC:  device id: 0x40, revision id: 0x31, emrev 0, prog id fff
Loading Environment from MMC... OK
In:    serial
Out:   serial
Err:   serial
Model: Toradex Colibri iMX8 QuadXPlus 2GB Wi-Fi / BT IT V1.0B, Serial# 06558677

  - SCFW 06bba0fa, SECO-FW d7523fe8, IMX-MKIMAGE dd023400, ATF a-20190
  - U-Boot 2018.03-toradex_imx_v2018.03_4.14.78_1.0.0_ga-bringup+gd06de417f2 

flash target is MMC:0
Net:   eth0: ethernet@5b040000 [PRIME]
Fastboot: Normal
Normal Boot
Hit any key to stop autoboot:  0 
MMC: no card present
switch to partitions #0, OK
mmc0(part 0) is current device
Scanning mmc 0:1...
Found U-Boot script /boot.scr
2416 bytes read in 8 ms (294.9 KiB/s)
## Executing script at 86000000
586 bytes read in 63 ms (8.8 KiB/s)
115038 bytes read in 68 ms (1.6 MiB/s)
23452160 bytes read in 412 ms (54.3 MiB/s)
9914087 bytes read in 218 ms (43.4 MiB/s)
## Flattened Device Tree blob at 84000000
   Booting using the fdt blob at 0x84000000
   Loading Device Tree to 00000000fd65b000, end 00000000fd67a15d ... OK
/dma-controller@591F0000, 65984
/dma-controller@599F0000, 66872
/dma-controller@5a1f0000, 65108
/dma-controller@5a1f0000, 65108

Starting kernel ...

[    0.391006] dmi: Firmware registration failed.
[    2.356748] mcp251x spi0.0: MCP251x didn't enter in conf mode after reset
[    2.363761] mcp251x spi0.0: Probe failed, err=16
[    2.391308] Can't support > 32 bit dma.
[    2.775494] rtc-ds1307 17-0068: hctosys: unable to read the hardware clock
Starting version 243.2+

TorizonCore 4.0.0-devel-202004+build.3 colibri-imx8x-06558677 ttyLP3

I have an imx8x with Viola Plus with these characteristics above.

I have IP 192.168.1.XXX but I can’t access SSH because the seller doesn’t remember the password. (I’ve already tried torizon/torizon and another password, like bobert that the seller suggested, but to no avail)

I tried to access via UART-TTL with cp2102 and ftdi adapters (ft232rl) I can see the images in Ubuntu (sudo picocom -b 115200 /dev/ttyUSB0) but I can’t type username and much less password because the keyboard doesn’t work at this time .

In the UART-TTL adapter I am correctly connecting the RX, TX and GND cables. I don`t use 3.3v or 5v in cp2102 or in ftdi UART-TTL adapter

How to proceed (in this case) to put torizon 6.6.1 (Or any other for testing) on ​​this device?

Greetings @neuberfran,

Seeing as you have a very old software version. 4.0.0 Torizon was not even an officially released version by us. The most straightforward path would be to put your system into recovery mode and then use Toradex Easy Installer to flash a new image. Is this something that would work for your setup? Or do you have further restrictions preventing this?

Best Regards,

@jeremias.tx Thanks for the quick response. I have no restrictions on my part. Torizon 4.0 does not support access via UART-TTL, is that it? Please go through the steps of putting my system into recovery mode and using Toradex Easy Installer

To put your device into recovery mode you can follow the article here: Loading Toradex Easy Installer | Toradex Developer Center

Best Regards,

@jeremias.tx I don`t see Viola PLus Carrier Board in this photo. WHy

I don’t have a Viola Plus carrier board, but in the schematics I can see that mounting resistor R49 should enable the recovery mode.

@vix Could you please be more detailed in showing how I can put my Viola Plus with Imx8x in recovery mode?

Note. : Even though you don’t have this Carrier Board on hand.

The Viola board does not have a CPU and cannot be put into recovery mode. However, the module inserted into a Viola board can be put into recovery mode using one of the methods described here.

@alex.tx I can’t see Viola Plus in this list

  • Power off your board.
  • Short-circuit pads with tweezers or piece of wire:
  • Power on your board while holding the pads shorted.
  • Unshort the pads after a few seconds.
  • The module will then be in recovery mode

@alex.tx I still haven’t got it, error: Wait for Known USB Device Appear…

I have the viola plus and I ask:

  1. Why do I connect the mini-USB to the viola and the host PC and I don’t see anything in /dev/ttyUSB?
  2. Does the viola plus have otg?
  3. at the time of recovery(Power on your board while holding the pads shorted.) can I connect the ftdi-USB-TTL adapter to the Viola<->PC Host?

Finally, I managed to ssh

It’s not expected behavior. In recovery mode, the NXP downloader does not mimic USB-to-serial functionality. If you are running Linux, you will need to configure the respective USB device functionality


Yes, you can, but what kind of results are you expecting?

@alex.tx I still can’t get rid of the Wait for Known USB Device Appear error…

I saw somewhere that the Viola Plus (and not the normal Viola) would have OTG. Therefore, question 01 above is meaningless, as the Viola Plus does not have OTG.

Updates to this topic: The name of this topic ends with without USB-UART TTL because I was connecting the RX/TX to 25 and 26 and not to 26 and 27. Now I have ssh and UART-TTL access.
Being above, I have access to U-boot now and have ums 0 mmc 0, command. Can this help me with something (like using balenaEtcher) to flash Yocto or TorizonOS or not?

I say this because Power’s act on his board while holding the shorted pads. (For 6 seconds + or -) has not worked.

@neuberfran I can only guess, reading the technical docs and what @alex.tx wrote.

  1. I would mount R49 on the ViolaPlus carrier board (no idea on the proper value - maybe 10k?) so that Recovery Mode is enabled
  2. I would short-circuit pads on the SoM itself as @alex.tx suggested in his message

It’s only an idea, since I don’t have a Viola Plus carrier board

@vix If I do number 01 above will I be exempt from number 02?

I think so; or, at least, this is what I guess reading the docs (but I admit that the situation is not clear).
I don’t have a Viola and/or a Colibri here.
Here you can find step by step procedure for Colibri iMX8X and Colibri Evaluation Board, and it seems that pressing recovery button is enough (as other SoMs).
If you look the schematics for the Colibri Evaluation Board you see that pressing the recovery button pulls to GND the OE# pin (SODIMM 91).
And so, this would be the only necessary step for every carrier board.
But inside the same schematics you see the following note:
So it’s not clear to me if recovery can work or not for Colibri iMX8X.

If you look to the Viola schematics, you see that mounting R49 (step 1 above) connects OE# pin to GND.
So, if recovery works, step 1 is the only step (step2 is not necessary).
But then you must remove R49 when you don’t need recovey mode anymore.

@vix I really don’t feel confident doing step 01 (despite having already purchased an R10) and I haven’t been successful with step 02 either (as per the photo, I’ve already adapted a cable and waited 6 seconds or a little more and it never goes into recovery mode It’s just not worse because we have discovered the password and can enter emmc 0 via ssh or UART-TTL console.

JP1 ???

@jeremias.tx @alex.tx @vix

How to solve this issue When I try boot from mmc 1 (sdcard with easy installer)?

Colibri iMX8X # mmc list
FSL_SDHC: 0 (eMMC) > FSL_SDHC: 1 >
Colibri iMX8X # mmc dev 1
Colibri iMX8X # saveenv
Colibri iMX8X # reset
mmc1 is current device
Scanning mmc 1:1…
Found U-Boot script /boot.scr > 1767 bytes read in 14 ms (123 KiB/s) > ## Executing script at 86000000 > 52 bytes read in 11 ms (3.9 KiB/s) > 44598236 bytes read in 2021 ms (21 MiB/s) > Bootargs: quiet video=DPI-1:640x480-16@60D initcall_blacklist=vpu_driver_init rootfstype=squashfs root=/dev/ram autoinstall clk_ignore_unused pci=nomsi > ## Loading kernel from FIT Image at 8a000000 … > Could not find configuration node > ERROR: can’t get kernel image! > SCRIPT FAILED: continuing…

@jeremias.tx @alex.tx @vix