What is the username and password for the TDX-X11 image?

Hi. I am using a custom image based on the tdx-reference-multimedia-image. I want to use X11 for properly using the virtual keyboard with the GTK framework (Weston has some incompatibilities).

So, in local.conf I changed the DISTRO = "tdx-xwayland" to DISTRO = "tdx-x11" and it compiled fine. However, after booting, the desktop environment does not start; instead, a login screen appears requiring a username and password. I have tried root and blank password, root-root, root-admin, but none of them work.

I mention that the local.conf file also contains some lines for defining a default root password, as follows:

EXTRA_IMAGE_FEATURES=""
INHERIT += "extrausers"
EXTRA_USERS_PARAMS = "usermod -p 1234 root"

I’ve also tried root with password 1234 and viceversa, but with no success.

Does anybody know how I can login and use the X11 image?

Hi

While I don’t know the answer to your question, have you tried to give the password with the ‘-P’ option (i.e. capital P) to usermod and rebuild and redeploy the image?

https://www.yoctoproject.org/docs/current/mega-manual/mega-manual.html#ref-classes-extrausers

Max

Hi. Thanks for the suggestion. I have commented these lines from local.conf and finally accesed the command line using the username root and blank password. However, the X server is not running and I do not know why.

Hi @CristianM ,

I built the tdx-reference-multimedia image just changing the DISTRO on local.conf to tdx-x11 and had no issues with the user login. Can you confirm that this is only change you have done?

Also the X server runs by default, can you check what is the status for the xserver-nodm service?

Best regards,

Daniel Morais

Hi. Below you can find all the changes I have made to the local.conf file (the packages I’ve included):

IMAGE_INSTALL_append = "python3"
IMAGE_INSTALL_append = " python3-pip"
IMAGE_INSTALL_append = " python3-spidev"
IMAGE_INSTALL_append = " python3-requests"
IMAGE_INSTALL_append = " python3-smbus2"
IMAGE_INSTALL_append = " python3-gpiod"
IMAGE_INSTALL_append = " program"
IMAGE_INSTALL_append = " modemmanager"
IMAGE_INSTALL_append = " networkmanager"
IMAGE_INSTALL_append = " gtk+3 python3-pygobject cairo"
IMAGE_INSTALL_append = " matchbox-keyboard"

IMAGE_INSTALL_remove = " ofono connman connman-gnome connman-client connman-plugin-ethernet connman-plugin-loopback connman-plugin-wifi"
# To finally remove ofono
DISTRO_FEATURES_remove = " 3g"

CORE_IMAGE_EXTRA_INSTALL += " python3 python3-pip python3-smbus2 python3-spidev networkmanager"

I’ve checked that status of the xserver-nodm using the following command:

systemctl --no-pager status xserver-nodem
Unit xserver-nodem.service could not be found.

But it says that the service was not found. These are all the services that are running:

 systemctl --no-pager status
● colibri-imx6ull
    State: running
     Jobs: 0 queued
   Failed: 0 units
    Since: Thu 1970-01-01 00:00:03 UTC; 51 years 2 months ago
   CGroup: /
           ├─init.scope
           │ └─1 /sbin/init
           └─system.slice
             ├─rngd.service
             │ └─107 /usr/sbin/rngd -f -r /dev/hwrng
             ├─systemd-timesyncd.service
             │ └─128 /lib/systemd/systemd-timesyncd
             ├─nfs-statd.service
             │ └─368 /usr/sbin/rpc.statd -F
             ├─system-dropbear.slice
             │ └─dropbear@0-192.168.61.80:22-192.168.61.79:51104.service
             │   ├─418 /usr/sbin/dropbear -i -r /etc/dropbear/dropbear_rsa_host…
             │   ├─419 -sh
             │   └─427 systemctl --no-pager status
             ├─NetworkManager.service
             │ └─352 /usr/sbin/NetworkManager --no-daemon
             ├─dbus.service
             │ └─191 /usr/bin/dbus-daemon --system --address=systemd: --nofork …
             ├─dnsmasq.service
             │ └─385 /usr/bin/dnsmasq -x /run/dnsmasq.pid -7 /etc/dnsmasq.d --l…
             ├─avahi-daemon.service
             │ ├─365 avahi-daemon: running [colibri-imx6ull.local]
             │ └─369 avahi-daemon: chroot helper
             ├─system-serial\x2dgetty.slice
             │ └─serial-getty@ttymxc0.service
             │   └─388 /sbin/agetty -8 -L ttymxc0 115200 xterm
             ├─system-getty.slice
             │ └─getty@tty1.service
             │   └─383 /sbin/agetty -o -p -- \u --noclear tty1 linux
             ├─wpa_supplicant.service
             │ └─407 /usr/sbin/wpa_supplicant -u
             ├─rpcbind.service
             │ └─108 /usr/sbin/rpcbind -w -f
             ├─ModemManager.service
             │ └─364 /usr/sbin/ModemManager
             ├─systemd-logind.service
             │ └─328 /lib/systemd/systemd-logind
             ├─systemd-resolved.service
             │ └─354 /lib/systemd/systemd-resolved
             ├─polkit.service
             │ └─198 /usr/lib/polkit-1/polkitd --no-debug
             ├─systemd-udevd.service
             │ └─125 /lib/systemd/systemd-udevd
             ├─bluetooth.service
             │ └─366 /usr/libexec/bluetooth/bluetoothd
             ├─busybox-syslog.service
             │ └─190 /sbin/syslogd -n
             ├─systemd-journald.service
             │ └─109 /lib/systemd/systemd-journald
             ├─busybox-klogd.service
             │ └─187 /sbin/klogd -n
             └─systemd-networkd.service
               └─353 /lib/systemd/systemd-networkd

Do you have any idea what is wrong?

Hi @CristianM ,

Can you please rename your local.conf file and generate a new one running the . export, after this change just the DISTRO parameter to tdx-x11 and then build the tdx-reference-multimedia-image?

Best regards,

Daniel Morais

Hi. I did what you suggested and I confirm that the X server started automatically and the clock application was shown. It seems that the packages I’ve added/removed in local.conf had an effect on this behavior. Anyway, in my case I’ve enabled automatic login using getty@tty1.service.

Thanks for the feedback @CristianM