WEC7 1.4b2 Internet Explorer


We are using internet explorer (iesample.exe) to display our manual on screen.
I have added iesample and made a new ownn image.
With BSP 1.3 this did work: Our manual could be displayed.

With BSP1.4b2 this no longer works. At first I thought this problem is caused by the modified ipuv3flat.dll from my other thread. But this is not true. I also see the problems with original ipuv3flat.dll from BSP1.4b2.

If the html file is very small I see errors on serial debug output but the system does not crash.

If the html file is bigger (25 kilobytes with some embedded jpg-pictures of another 100 kilobytes the system crashes.

Kind regards
link text

We are working on the issue, trying to reproduce it.

It seems that Internet Explorer tries to allocate a large number of bitmaps in video memory.
This version of the display driver:
works with the simple page you linked in the other thread.
Can you please test it with your more complex content too?

Sorry, posted the wrong file.
this is the correct one.

Hello @valter.tx ,

good news: internet explorer now works without problems with our manual

bad news: 2D acceleration is now slower. With blttest.exe from my other thread with SCREENX 800/SCREENY 600 with previous ipuv3flat.dll I got times of 9-10ms, now I get times of 37-38ms.

Kind regards


maybe I should have been more precise: It is too slow now.
If you prefer I can post this in my other thread.

Kind regards

No, it’s fine here.
We are working on this. Seems that IE allocates a large amount of memory, we tried to keep some of this as regular (non video) memory, but this impacted performances.
I hope to be able to share a new version tomorrow.

New driver here:
it seems that explorer allocates 4 surfaces as big as the whole screen and this requires a large amount of memory. Now system memory is used when no video memory is available.
You should see some debug messages on the serial console, reporting the amount that was not possible to allocate, this may help you setting up enough ipumem in bootloader settings (you may reduce GPU memory if you don’t use 3d acceleration, but may leave 4-8Mb for the 2D accelerator.
Now your test app works with good performances and IE no longer crashes, even with complex pages.
Let me know if this works also on your use case.

Hello Valter,

when I navigate in internet explorer I get from time to time a message “no video memory available to allocate required buffer of 4147200 bytes”. Internet explorer works perfectly. This may be ok.

But my blttest.exe shows now for SCREENX 800 / SCREENY 600 a time of 40ms (this is slightly more than yesterday).

gpumem is still set to 0
ipumem is set to 33554432

You say that you got good times with my blttext.exe. I am wondering why I can not see these good times ?

Kind regards

I am running the test app at 800x600 and see 8-10ms
Do you get any other message during boot?

link text

Please see attached debug output during boot

can you check that you are using the latest update of the driver?
I am also testing @ 1920x1080

I have checked and I am quite sure that I use the latest driver.

I assume I would not get the debug message “no video memory available to allocate required buffer of 4147200 bytes” if I use not the latest driver.

Message was there also in previous versions.
But I don’t see the same behaviour here :frowning:
Tomorrow I’ll be able to send you a whole image, to understand if this makes a difference.
Sorry for not being able to do this earlier.

This is the image.
I tested it again, no issue on explorer browsing different sites and 8-9ms score running test app.
I have 64MB (increased) of IPU memory and 32MB (default) of GPU memory on 512MB imx6DL.

Hello @valter.tx,

even with your image I get values of about 40ms.
I installed your image, cleared the registry in boot menu, applied modifications to registry (see registry.txt) get get FullHD via HDMI.
I set ipumem to 64 MB.
Then I started blttest.ext (that one that I have sent to you July 2nd)

Please see attached screen shot.

I have done the test with winvnc in autorun folder and without (this did not make a difference).

Note that I have different hardware: iMX6Q 2GB

Kind regardslink text

Can you try to update also bootloader? I tried on Apalis and set memory to 64MB and see the correct behaviour.
Here’s a link to the new loader:

After updating to this boolloader my Apalis does no longer reboot. There is no message from bootloader.

I will try recovering

Hello Valter,

I entered recovery mode using hardware mechanism, used recovry-windows.bat to get to easy installer, installed the tezi image and then your 1.4b2 (both bootloader and image). Then I made some modifications to get FullHD-HDMI-output. Then I rebooted - everything was ok.

Then I tried again your https://share.toradex.com/njj9zlepii19k79 and I again the system does not reboot and I do not get any bootloader messages.

Kind regards

You have an imx6Q 2GB IT module, is that correct?
Can you please check and post it’s HW revision?
Are you using our EVB for testing?