Virtual keyboard in Weston?

Hi! I am developing a desktop app using Python and Gtk+3 running in the Weston environment. I am using the tdx-reference-multimedia-image.

I need to enable a virtual keyboard, but I could not find one in this Linux image.

Does anybody know how to include/enable a virtual keyboard?

Greetings @CristianM!

It seems that there’s weston-keyboard that should be installed with Weston, so you can use that (or any other on-screen keyboard) and configure your weston.ini file accordingly on the input-method section according to Weston documentation.

It will look a bit like:


Hi. I’ve tried the command /usr/libexec/weston-keyboard from the terminal and it said command not found. I’ve installed the matchbox-keyboard and included the line path=/usr/share/matchbox-keyboard in weston.ini, but nothing happens when I run the command matchbox-keyboard from the terminal. Am I doing something wrong?

Hello @CristianM ,

Could you please check in your file, ~/.config/weston.ini if a path is set for the # on screen keyboard input method. This command (path=/usr/libexec/weston-keyboard) that my colleague mentioned is to be added as a line in the weston.ini file. When the path and the appropriate keyboard configurations are made in the weston.ini, it will look something like this:

# on screen keyboard input method


And this should enable the weston-keyboard, while you run demo applications from weston-editor or other applications

Best Regards,

Thank you. It worked. I used /usr/libexec/weston-keyboard, because /usr/lib/weston/weston-keyboard did not exist. I think the actual solution was placing the weston.ini in ~/.config/weston.ini also (previously, it was located only in /etc/xdg/weston).

Now my problem is that the virtual keyboard is not displayed when accessing a text input box in GTK, due to the fact that Weston implements the interfaces for zwp_text_input_manager_v1, while gtk only supports zwp_text_input_manager_v3 (see link). However, if I use weston-editor, the virtual keyboard is displayed. Anyway, this is another problem (I will try Xorg/X11; hopefully, this problem will be gone).

Hello @CristianM ,

Glad to hear the solution worked for you. As for the ‘virtual keyboard is not displayed when accessing a text input box in GTK’, I would also try what you have mentioned. If you face any problems, please post it as a new question in the community.

Best Regards,

Thank you. I have already posted the question. Please see the question here.