Verdin iMX8M-Plus: Stop working during the setup

Verdin Development Board with a Verdin ImMX8M Plus

Hello All,
I was following the quick start guide, but when i was installing the the available Images, I received a message that it failed and I need to restart the process. Then, the screen just got frozen and I couldn’t start the process again. I used the RESET bottom, and Now, i am not able to see Toradex Easy Installer

does anyone know the reason why I got that issue and how to fix it without?

P.S> I am using a virtual machine

You can put your module into recovery mode and re-load the Toradex Easy installer over USB.

Thanks for the help.

I tied your suggestion, but I didn’t work.

A summary of what I have done:

1.- I was in the step 2 from the quick start guide section 1.2 Installing the Operating System, then I saw a message about something went wrong.
2.- I selected ok and the screen got frozen. No response using the mouse or keyboard.
3.- Then, I pressed the reset bottom and Now, I am not able to see the Torodex Installer.
4.- I tried to put the module into recovery model, but it didn’t work( I was comparing the output of lsusb on my computer before and after entering recovery mode.) I tried multiple times with multiple computers because i was thinking I had some firewalls that doesn’t allow me to download Torodex Easy Installer.

Any more ideas.
Is this a hardware issue?

Could you please provide more details?

  1. What exactly was the error message you encountered?
  2. What do you observe on the debug serial port after a reset?
  3. How did you put the module into recovery mode? Did you connect a USB-C cable between the Development board’s X34 connector and your development machine? It can be challenging to manage USB_OTG on a virtual machine. Please try using a native machine (OTG download is supported on both Linux and Windows).
  • You said “I was thinking I had some firewalls that doesn’t allow me to download Torodex Easy Installer” Does this mean you’re unsure if you’ve successfully downloaded the Toradex Easy Installer? Just click on the appropriate link and check your browser’s messages to see if the file was downloaded or not.

1.- I completed step 1.2 from Installing the Operating System | Toradex Developer Center

I tried to complete step 1.2, but when I power the board, there is nothing in my screen.

I tried to follow the quick start again but i don’t see any information on the screen ( screen goes to standby mode)

I tried to Run the Recovery Mode Script, and i get this.


There is not progress after hours, same message

2.- I am not sure about this, but i see this when i connect the connector (X66) .


I tried the same using connector X34 but i didn’t work. Using X34 i dont see any COM

3.- Yes. I am using my machine and download the OS image.

I tried to use a different machine but i got a message when i use my company’s machine .

  • X34 is intended for downloading the recovery image and does not function as a COM port.
  • Have you attempted to use X66 and configured your terminal program for COM6?
  • The recovery script will fail if a USB cable is not connected to X34 or if the module is not in recovery mode.
  • Could you please describe the exact steps you took to put the module into recovery mode?

yes, i tried with X34 and x36 using multiple computers following this instructions (3.1.1 and 3.1.2)

  • I tried again using X34, but no response
  • I havent tried to use X66 and configured my terminal program for COM6

when i use the X34 port and start to follow the steps i get this

no progress after hours

Do you have some other Verdin module?

Yes , we have like 5 modules:

On Monday, I will try to test the other modules.
However, I can’t understand why I couldn’t install the operating system.

I saw the Torodex Easy installer on the screen, it got frozen and then Iam not able to see it again anymore.

Take a new Verdin module and establish a connection with the Serial debug port. Then we will move forward with your failed one.

Hi @ronaona ,

Have you managed to establish a connection to the Verdin Serial Debug port CLI?


Yes, I did, I followed your steps again, but this time I was making sure i didnt have any firewall. The first time i tried to setup Torodex, but it seems there was a problem when i download the OS.

I also had to run the windows application becasue i had some limitation with my linux applications

Now, everyting is working. Thank you for the thecnical support.