Verdin AM62 WiFi not working

Device Information:

  • Board: Verdin AM62 Dual 1GB Wi-Fi / Bluetooth IT
  • Carrier Board: Yavia Carrier Board V1.0A
  • Operating System: TorizonCore
  • Kernel: 6.1.46-6.5.0

Issue Description:

I followed the quickstart guide for the Verdin AM62 and Yavia boards, including the installation of the latest TorizonCore with evaluation containers. Unfortunately, I encountered an issue with the Wi-Fi functionality, specifically at step 1.4 “Basic Wi-Fi Usage with Torizon.”

Problem:

When executing the command nmcli device wifi list, the expected behavior should be to list available Wi-Fi hotspots; however, this command does not produce any results. Additionally, the nmcli device wifi rescan command results in the error message: “No Wi-Fi device found.”

Output of Relevant Commands:

Here is the output of the commands that I ran:

root@verdin-am62-15133452:/# nmcli device wifi list
root@verdin-am62-15133452:/# nmcli device wifi rescan
Error: No Wi-Fi device found.
root@verdin-am62-15133452:/# nmcli device
DEVICE TYPE STATE CONNECTION
ethernet0 ethernet connected network0
ethernet1 ethernet unavailable –
br-249fd1509a8f bridge unmanaged –
docker0 bridge unmanaged –
can0 can unmanaged –
can1 can unmanaged –
sit0 iptunnel unmanaged –
lo loopback unmanaged –

Additional Information:

  • I also ran lspci -v and lsusb to check for Wi-Fi hardware devices, but there was no information related to Wi-Fi devices in the output.

root@verdin-am62-15133452:/# lspci -v
root@verdin-am62-15133452:/# lsusb
Bus 001 Device 002: ID 0424:2514 Microchip Technology, Inc. (formerly SMSC) USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Steps Taken:

I have attempted to install previous versions of TorizonCore with the same result. It appears that the Wi-Fi hardware may not be recognized or enabled.

Expected Outcome:

The expected outcome is for the nmcli device wifi list command to list available Wi-Fi hotspots, allowing me to connect to the desired one as a client.

Additional Notes:

Please let me know if you require any further information or diagnostic output to assist in resolving this issue.

Hello @baska

Our dev team is aware of an issue in the TorizonCore builds that causes breakage of wifi. It looks like there is a packaging issue with the firmware binary. To make sure you are seeing the same thing as us, run the command sudo dmesg | grep wifi and you should see messages about firmware load issues.

The team is on it and we’ll get it fixed in a nightly soon.

Drew

Hi @drew.tx

Thank you for your prompt response and the information you provided. I ran the command you mentioned, and here is the result:

[ 12.328838] mwifiex_sdio mmc2:0001:1: Direct firmware load for mrvl/sdiouartiw416_combo_v0.bin failed with error -2
[ 12.328883] mwifiex_sdio mmc2:0001:1: Failed to get firmware mrvl/sdiouartiw416_combo_v0.bin
[ 12.328891] mwifiex_sdio mmc2:0001:1: info: _mwifiex_fw_dpc: unregister device

Thanks for your assistance and support. Please keep me posted on any updates or when a fix is available in a nightly build.

Hello @baska

This is fixed in the latest nightly. Please give it a try and let us know if you have further issues.

Drew

1 Like