Using QSPI as a /dev/spidev or equal

Hi i have tried to configure the imx7 QSPI as a /dev/spidev

but also found this, which says “not possible”

Is this “simply” a matter of Linux drivers ? In order to try different QSPI devices and also possibly use DQS clock-feedback function it would be nice to have a /dev/xxx accessable from user comand line.

I tried the devicetree entry below and got /dev/spidev4.0 , but trying to write to it with the spidev_test.c example from the documentation - results in error -524

Also tried asking for dts/dtsi settings in NXP forum, but got no reply

Setting “compatible” to evalspi , could be first mistake…

&qspi1 {
pinctrl-names = "default";
pinctrl-0 = <&pinctrl_qspi1_1>;
status = "okay";

spidev1: spidev@0 {
compatible = "toradex,evalspi";
reg = <0>;
spi-max-frequency = <33000000>;
spi-rx-bus-width = <1>;
spi-tx-bus-width = <1>;
status = "okay";

hello, the QSPI is meant for QSPI flash memory devices.

Best Regards,


i know that is what is currently supported - we were just trying to test QSPI SRAM and a A/D converter with QSPI - but if there is no support for acessing the QSPI via “standard” /dev device driver, the test cant be with Linux. Maybe well try using the M4, but that is beyond the current project limits.
so - thanks for your feedback,