Unable to load Toradex Easy Installer on Apalis iMX8

Hi, I have a board with Linux console image Apalis iMX8 (3.0.4) loaded and running on it. I am trying to load a different image on it. I am thus trying to first load the Toradex Easy Installer on it, following the instructions on this site Downloads & Installers | Toradex Developer Center.
I entered Recovery mode and tried to run the windows .bat script from my windows 10 host machine. The error I get is -
The system cannot find the path specified.
Echo is off.
Downloading Toradex Easy Installer failed…

Could you please provide HW version of your Apalis iMX8 module? Please capture and share full output when you running “the windows .bat script”

The HW version is Apalis iMX8QM 4GB WB V1.0B. The output of the script is attached.

Seems to be an error with the Windows Batch script itself. Based on the error if I were to guess it can’t find the uuu.exe executable. I believe the script tries to look for it in the following path relative to where the script is executed “recovery/uuu.exe”. Could you see if you could find this file? Perhaps it’s missing or not where the batch script expects it to be.

Best Regards,

I have shown the folder structure in the attached image. There is no recovery folder, but there is a uuu.exe executable. I tried to edit the script so that it doesn’t go into the recovery folder and goes directly to uuu.exe, but that gives me an error as well. I have attached another image showing the error.

Alright I think I know what the issue is, some of our recent builds of Easy Installer have an issue where there is no recovery folder. Seems you may have one of these problematic versions.

While I look into this further internally use this version of Easy Installer here: https://share.toradex.com/6my5maqmge9d8x1

This should work as it has the recovery folder intact and it’s what I use personally.

Thank you for reporting this issue so we can try and resolve it.

Best Regards,

Hi, I downloaded the zip file for Apalis iMX8 V1.0B and newer Toradex Easy Installer, and ran the recovery-windows.bat script as before. I got a message saying that the download was successful. However, when I connected the board to a display monitor via the HDMI port on the board, and turned the board on, the user interface did not appear on-screen. It just showed the previous image (Linux console image Apalis iMX8 (3.0.4)) that had been on it previously. I want to download a different image, which was why I loaded the Toradex Easy Installer in the first place. I have attached the output to the screen here. Please let me know if I’m missing anything.

alt text

What do you see over the serial console while you’re running the the batch script?

Via serial you should see the Easy Installer being loaded and then the system booting into the Easy Installer software.

Also you mentioned after the download was successful you " turned the board on". Could you clarify? You don’t need to power-cycle the board after the download it should automatically boot into Easy Installer after the download. Just to clarify the script loads Easy Installer into RAM and is run out of RAM. If you power-cycle at any point before flashing a new image the system will boot into the previous image since nothing was written to flash.

Best Regards,

How do I connect to the serial console?

See how to connect cable at step 3 and step 4 . Then run any terminal app (putty, terarterm. minicom etc) on your dev machine. Default baud rate is 115200

Hi, sorry I am very new to all of this. I’m trying to connect via the serial cable and I have it connected according to the instructions provided on the webpage you had linked to. I tried to connect via putty, but I discovered that the board isnt appearing on any Com port on my windows PC. I tried to VNC to it as well, but I get an error that says RFB protocol error, bad desktop size.

I had thought that connecting to an external screen via an HDMI cable would fulfil the same purpose. What am I missing?

An HDMI output as wel ass VNC works only when OS is booted. Serial debug console is active right after bootloader stage.

Which USB to serial adapter you are using?

I switched the cable, so I do actually see the Com port connection in the Device Manager. Upon setting the com port and baud rate in Putty, I then ran the recovery script. However, the serial console remained blank, though the script succeeded. What could I be missing?

It’s hard to say. Your cable can be wrongly connected, or it can be damaged. USB to serial adapter can be faulty. Serial port can be incorrectly set or many other reasons. Try to eliminate possible causes one by one.

Hi, I obtained a new serial cable, and can now see an output on the serial console when I run the recovery script. I then unzipped the file containing the image I wanted to flash onto a USB drive and plugged it into the board. However, I got an error as shown in the attached image. I also tried running the recovery script with the USB plugged in, but I got the same error (shown in image).

To clarify it looks like you were able to get Easy Installer running, correct? So the UI shows up properly on the connected display?

So is the issue that the software image on the USB doesn’t show up in the Easy Installer UI? If so then perhaps the issue is that the USB isn’t formatted correctly. Only the following filesystem types are supported: ext2/3/4, FAT and NTFS.

Best Regards,

The unzipped folder of “Toradex Easy Installer” should contain the sub-folder “recovery” which should contain 3 files with “uuu” name:

  1. uuu
  2. uuu.auto
  3. uuu.exe

The script recovery-windows.bat tries to find file uuu.exe in subfolder “recovery” to run it.
This script fails if it cannot find uuu.exe in sub-folder “recovery”.

The web-site artifacts.toradex.com has many folders where there are many variants of TEI, most of them are plain folders without subfolder “recovery” and files “uuu.*” in it.
For example:


Only one proper zip-file is here:

This zip-file has valid structure inside (subfolder “recovery” and “uuu”-files in it).

I lost a lot of time to figure it out.

The UI does not show up on the connected HDMI display at all.
I connected the HDMI cable to a display, connected the ethernet cable, turned the board on in recovery mode, and ran the recovery.bat script. The output of the serial console was as I showed in the post above, but there is no output on the connected HDMI display.

Hmm this is very odd this happened rarely before but should’ve been fixed. Recently we published known working versions of Easy Installer so you don’t have to go to the nightly feeds anymore. Could you try the appropriate Easy Installer from this list: Downloads & Installers | Toradex Developer Center

If the problem still persists with this newer version can you provide your dmesg logs so I can take a look.

Best Regards,

I did end up installing the beta version of the Installer, and the problem I am sharing is for that version. How do I look at dmesg logs?