Touchscreen PenMount PM6500 on Colibri

Hi, I have to use the touchscreen PenMount PM6500 on Colibri iMX6 via USB.
Can I use a driver in this list Manufacturer of Resistive | PCAP Touch Screen | PenMount Touch Screen Controller - AMT?
If no, what are the compatible touch screens?
Thanks for your help. Regards Davide

I am not familiar with the device. It seems that there is a driver for the serial variant in upstream Linux, but not for the USB variant.

It seems there is a driver for Tizen 1.0 which might be your best bet. It seems to use tslib but there is only a binary in for x86 available, so if there have been changes to it then you are out of luck.

You have to ask AM Touch whether they have a driver for ARM (armhf).

Hi Stefan, thank you for your replay. Do you know what I have to enable for the driver in the upstram Linux for PenMount PM6500? Regards Davide

I can use also this controller touch Hampshire TSHARC-12. Where I found the driver available in the Linux image? Regards Davide

Sorry the link is http://www.microchip.com/design-centers/tsharc/software-drivers-and-driver-manuals.
Other question, there is a external USB controller recommended / tested from Toradex?
Regards Davide

Thanks for the link. If you have the driver for ARM, you can use this touch controller
Concerning the external USB touch controller, we do not have much experience with them, but there are two discussions (first and second) concerning usb touch controller, where you can get some more Information.

Thank you for help. I will try serial PenMount.
Regards Davide

You are welcome. Thanks for the feedback.

Thank you Stefan
I tried to compile inputattach, but it requires the “libsdl1.2-dev” library. Do I have to put this library inside the SDK (crosscompiler environment-setup-armv7at2hf-vfp-neon-angstrom-linux-gnueab) right? Is it possible to enable it inside the Yocto?
Regards Davide

Great Stefan, I try now.
Regards Davide

Thanks for the feedback.

Hi Stefan, now touch screen work well. Thank you Davide

Hi, Perfect that it works. Thanks for the feedback.

Hi Stefan.
I moved from kernel 4.1 to kernel 4.9. Now when I run inputattach --penmount6000 /dev/ttymxc2 I see error “inputattach: can’t set line discipline”.
I do not understand why. In the new kernel CONFIG_TOUCHSCREEN_PENMOUNT is present as kernel module as old kernel. In device tree in the uart0,1,2 I have disable dma rx and dma tx for serial port to touch works correctly.
Do you have any advice?

Could you try the command inputattach --dump /dev/ttymxc2?

Hi, with --dump I have no error, but the touch doesn’t work.
Thanks

Ok. Could you check with lsmod if the kernel module for penmount is loaded? Could you provide the dmesg log?

Hi, thank you for your support. lsmod is always empty (before and after inputattach). Penmount serial driver is a kernel driver (not kernel module). In 4.1 kernel it worked as kernel drivers. Should I turn it into a kernel module?
I also tried with ttymxc0 and ttymxc1. Regards Davide
Attach my log:[link text][1]
[1]: https://share.toradex.com/qfqvvuoqra0cx6a?direct

Yeah, you are right about the serial driver to be a kernel driver and not module, which should be placed in /lib/modules/$(uname -r)/kernel/drivers/. Could you check if it is there?

Hi, sorry for the delay … last week I was on vacation :slight_smile:
In kernel/drivers/input/serio I see serport.ko. In kernel/drivers/input/touchscreen I see atmel_mxt_ts.ko and fusion_F0710A.ko. Should I also see PenMount?
With “cat /proc/config.gz | gunzip | less” I see CONFIG_TOUCHSCREEN_PENMOUNT=y.
I generate filesystem with bitbake and after replace kernel, because the kernel is compiled out of bitbake.
Regards Davide