Torizon, iMX8 with a built dunfell image won't start

This is similar to a post from July 2020, but it’s the same problem -

The latest TorizonCore dunfell release builds fine but doesn’t boot, has the following specs -

Colibri iMX8 V1.0B
Colibri eval board V3.2B
Torizon V5, machine set to ‘colibri-imx8x-v10b’

iMX8 fails to boot and the RESET OUT light just blinks. The original post mentions supporting older silicon, but this is a V1.0B version module.


Greetings @buchmeister,

I don’t seem to be having any issues on my side with the latest Torizon build on i.MX8X V1.0B.

First of all could you explain why you’re building TorizonCore in the first place? Are you looking to make some kind of change to the image or such that can’t be done with torizoncore-builder?

Next, do our pre-built images for TorizonCore flash and run on your device?

Judging by your description however it sounds like you flashed an image not meant for the 1.0B version. Are you absolutely sure you’re build is configured for the right machine?

Best Regards,

  • We’ve built images from the start, so this was no different…we have a custom device tree and I’m new to torizoncore-builder.

  • I started with the prebuilts, but had issues. I verified those again this morning by trying to use the image ‘TorizonCore with evaluation containers for HW V1.0B’. After flashing the module, it wouldn’t boot - loops on the ‘Torizon’ splash screen but goes no further

  • I’m positive the source I pulled and bitbaked was dunfell V5 with the MACHINE set to ‘colibri-imx8x-v10b’

  • module is fine because I can flash it with a colibri V3 B3 image and it works as expected

But I’ll try the prebuilt again.


The pre-built images should work find I just double-checked this.

However another issue might be that your 1.0B module doesn’t have the proper fusing. To run our latest images the old 1.0B modules need to have correct fusing. The older 1.0B modules did not come with this fusing by default.

Try the following to see if your module has the correct fusing:

  • First flash your module with a working image. It doesn’t matter what as long as it has a working U-Boot that you can access.
  • Access the U-Boot console by interrupting the boot sequence.
  • In the U-Boot console run fuse read 0 765
  • If the previous command returns all 0’s then this means your module isn’t fused properly.
  • If and only if your module returned all 0’s you can apply the proper fusing by running fuse prog 0 765 00983e91.

Try this and let me know whether it works or not.

By the way it would probably be for the best in the long-term to try and get your hands a more up to date version of the Coibiri i.MX8X, instead of the 1.0B version. Please contact your Toradex sales contact and see if you can get your modules upgraded.

Best Regards,

Thanks for the fusing info…we’re under a tight timeline right now, so I’ll try it when I can. We did get a recent shipment and one of them was a ‘1.0D’, so I tried that. I flashed it with a pre-built Torizon image and that worked fine.

thanks again,

I flashed it with a pre-built Torizon image and that worked fine.

That’s good to hear. I would suggest to work with the 1.0D modules as much as you can going forward. While we do still create images for the 1.0B modules, they can have strange quirks and issues due to the older silicon on those modules.

Best Regards,