Store not empty question


How can I fix this error? I have always worked from this directory but for some reason it’s not working anymore.

torizoncore-builder images unpack torizon-core-docker-colibri-imx6ull-emmc-Tezi_5.7.0+build.17.tar

Storage not empty. Delete current image before continuing? [y/N] y
Unpacking Toradex Easy Installer image.
An unexpected Exception occured. Please provide the following stack trace to
the Toradex TorizonCore support team:

Traceback (most recent call last):
  File "/builder/torizoncore-builder", line 217, in <module>
  File "/builder/tcbuilder/cli/", line 145, in do_images_unpack
  File "/builder/tcbuilder/cli/", line 139, in images_unpack
    images.import_local_image(image_dir, dir_list[0], dir_list[1], dir_list[2])
  File "/builder/tcbuilder/backend/", line 274, in import_local_image
    subprocess.check_output(tarcmd, shell=True, stderr=subprocess.STDOUT)
  File "/usr/lib/python3.9/", line 424, in check_output
    return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,
  File "/usr/lib/python3.9/", line 528, in run
    raise CalledProcessError(retcode, process.args,
subprocess.CalledProcessError: Command 'cat /workdir/torizon-core-docker-colibri-imx6ull-emmc-Tezi_5.7.0+build.17.tar | cat | tar -xf - -C /storage/tezi.tmp' returned non-zero exit status 2.

Kind regards,


Hello @sirhc
It might be that the .tar file is not in the same directory where you execute the torizoncore-builder command. It’s not uncommon:

Best regards,

Hi Josep,

it’s in the same directory. I tried the imx8x tar file. That one is working without any problems. What am I missing?

torizoncore-builder images unpack images/torizon-core-docker-colibri-imx8x-Tezi_5.7.0+build.17.tar
Storage not empty. Delete current image before continuing? [y/N] y
Unpacking Toradex Easy Installer image.
Copying Toradex Easy Installer image.
Unpacking TorizonCore Toradex Easy Installer image.
Importing OSTree revision ec744fac1d0a556c00400d205850fb443dc688efa478f2d8c60303430dcac227 from local repository...
1135 metadata, 12775 content objects imported; 530.9 MB content written
Unpacked OSTree from Toradex Easy Installer image:
  Commit checksum: ec744fac1d0a556c00400d205850fb443dc688efa478f2d8c60303430dcac227
  TorizonCore Version: 5.7.0+build.17

I had no issues trying to unpack torizon-core-docker-colibri-imx6ull-emmc-Tezi_5.7.0+build.17.tar with TorizonCore Builder.

Maybe there’s something wrong with this file on your side? What happens if you try to untar it yourself? Or maybe try deleting and re-downloading this file.

Best Regards,

Okay… first time such a thing happened to me… File was corrupted indeed.
Should have tried re-downloading before posting… Thanks for the tip!

Glad I could help!