IMX8 apalis is not booting up

After flashing the os image and switch it off and on again. The board is not booting up and not showing any booting logs in puTTy and fan is not turning too. When first time I flashed the os image, it was working and able to see output on lcd screen. I tried number of times to download the os image from toradex easy installer. After downloading the os image, when its asking for reboot, I am clicking that and its not working, its not booting up. Anyone help me on this?

Hello Mohar,

you mentioned that you are able to start the easy installer? Is this right?

Best Regards,


Yes I am able to start the easy installer

Hi @Mohar , have you try the latest Toradex Easy Installer V5.3.0 and click Erase on the
Toradex Easy Installer before flashing the OS image?

Hi @benjamin.tx Yes I did. I am not getting why the fan is not turning. Previously it was working . Any views on that?

Hi @Mohar , the fan is controlled by a GPIO. The software (Toradex Easy Installer, Linux or Torizon BSP) must be loaded to turn on the fan. What is your Apalis iMX8 hardware version? Is any log printed on the serial console after the image is installed? It is always good to wait for Toradex Easy Installer asking a reboot after the progress bar is complete. Which image do you choose to install from Toradex Easy Installer?

I chose Toradex multimedia image. I did reboot but still the fan is not turning. It was initially working. I was trying to install the torizon evaluation core but it keeps on booting and its looping. So I used toradex multimedia image. This one worked but the fan is not turning at all

The board is also not booting properly everytime when I switch it off and on again. I need to flash os image everytime then and after installing number of times sometimes it boots up, works properly
and again back to same

which carrier board are you using?
And which version of the Apalis IMX8?

Best Regards,

Matthias Gohlke

Its ixora carrier board

Apalis iMX8 QuadMax 4GB Wi-Fi / Bluetooth IT V1.1C

When I am flashing the image from toradex easy installer, after flashing is done I am switching off the board and switch it on again. After that no boot logs coming up in puTTy. The module is not booting at all

I am having the exact same Problem. The first time everything worked, but after flashing a different image it does not boot any more.

My guess is that it is still in recovery mode (still after complete power off): when using the easy launcher script on the PC, I don’t even need to connect the 2 pads to trigger the recovery mode.

I didn’t have checked yet, but my next step would be to use GitHub - boundarydevices/imx_usb_loader: USB & UART loader for i.MX5/6/7/8 series to start uboot from recovery mode and boot the kernel from there.

Hi @oklemencic and Welcome to the Toradex Community!

Could you tell us which version of Toradex Easy Installer did you use and which Software did you flash on the module?

Best regards,

From my side I was using Apalis-iMX8_ToradexEasyInstaller_5.3.0+build.3

I had flashed Toradex multimedia image

Any views on this why is not booting up correctly after switching it off and switching on again

I was using Apalis-iMX8_ToradexEasyInstaller_5.3.0+build.3

I flashed various images:

  • Apalis-iMX8_Reference-Multimedia-Image-Tezi_5.3.0-devel-20210521131121+build.0
  • Apalis-iMX8_Reference-Multimedia-Image 5.3.0 from 07/2021
  • Apalis-iMX8-Torizon Core 5.3.0 from 07/2021

Hope this helps,

Hi @oklemencic and @Mohar

I installed this version on my module, which is working fine: TDX Wayland with XWayland 5.3.0+build.10. Could you do the same and check if this solve your issue

Best regards,

The same with 5.3.0+build.10.
As additional info, here is the uart log when triggering the easy-recovery.

When booting the regular way, I don’t get any debug UART output…

U-Boot 2020.04-5.3.0+git.7f3416a28c34 (Jul 06 2021 - 15:49:48 +0000)

CPU:   NXP i.MX8QM RevB A53 at 1200 MHz

DRAM:  4 GiB
Loading Environment from MMC... OK
In:    serial
Out:   serial
Err:   serial
Model: Toradex Apalis iMX8 QuadMax 4GB Wi-Fi / BT IT V1.1B, Serial# 06804917

  - SCFW bc122ee1, SECO-FW d63fdb21, IMX-MKIMAGE 8947fea3, ATF 835a8f6
  - U-Boot 2020.04-5.3.0+git.7f3416a28c34

switch to partitions #0, OK
mmc0(part 0) is current device
Detect USB boot. Will enter fastboot mode!
Net:   eth0: ethernet@5b040000