Impossible to install TorizonCore on Apalis module

Hello community,

here my equipement :
-Ixora board V1.1A
-Apalis iMX6Q 2GB IT V1.1B
-Apalis iMX6Q 2GB IT V1.1C
-Pin for recovery mode

My problem was when i want to install TorizonCore i got this error (screenshot)
I try with toradex easy installer 5.7 with and without constainer, and image torizon core docker 5 and 6
I also try with 3 different usb stick

Can someone help me ? :sweat_smile:


Hello @Fonky,

Part of the error from your picture states; " Read only file system." We do have a known issue with some IMX6 where the eMMC goes into a forced read only state. We have a write up for it here:

Would you mind downloading and running the script to see if this is an issue that pertains to your setup?


Hello @eric.tx ,

Should i insert script using tera term or i can use Linux ubuntu (windows powershell)

hey @Fonky,

Either way should be good if you can get the script package onto the device and run it.


Hello @eric.tx ,

I dont know why but since 2 days i got same error

fonky@Fonky:/mnt/c/Users/Elafi/OneDrive/Bureau/check_package$ sh 7: ./MX52LM04A11XUI_check: Exec format error


fonky@Fonky:~$ sh /mnt/c/Users/Elafi/OneDrive/Bureau/Apalis-iMX6_ToradexEasyInstaller_5.7.2+build.14/
Downloading Toradex Easy Installer...
sudo: ./recovery/imx_usb: command not found

Downloading Toradex Easy Installer failed...

I try with linux ubuntu using windows powershell (windows 11) and with my other computer Linux debian 11

Edit : i also did : chmod +x

Hi @Fonky ,

Did you also try to do this?

chmod +x imx_usb

This might fix this behaviour.

Best Regards

Hello @kevin.tx

Last night, after several error messages,
I tried to connect the ixora card via ethernet,
Some image appeared including the one I wanted and the installation went perfectly!

Thanks for your help !

1 Like

Hi @Fonky ,

Glad to hear that. If you have further issues, feel free to open a new post.

Best Regards

1 Like