I am getting error pcilibs after installing net-snmp-server in imx7D


i am getting error while configuring the snmp
Copy snmpd.conf to /usr/local/share/snmp on target
update-rc.d snmpd.sh defaults
opkg update
opkg net-snmp
opkg net -snmp-server
snmpd -f -L -DjisnuAUPCmib
then starting the snmp


Hi, I’m the Toradex AI Assistant. I’m in early beta, and I would appreciate your feedback.
The Toradex Support team will follow up with you shortly!

Did you like my answer?

:+1: :-1:


Hello,

To address the issue of encountering a “pcilibs” error after installing the net-snmp server on a Colibri iMX7D module, it’s important to understand that this error might be related to missing PCI library dependencies required by net-snmp for certain operations. The Colibri iMX7D, based on the NXP i.MX 7Dual SoC, does not inherently support PCI, which could be why you’re encountering this error.

Here are steps to troubleshoot and potentially resolve this issue:

  1. Verify the net-snmp Configuration: Check if the net-snmp configuration is attempting to use any PCI-related features or if there’s a way to disable PCI checks within its configuration.

  2. Install Missing Libraries: If the error is due to missing libraries on your system, you can try installing the PCI utilities library (libpci3 on Debian-based systems, for example). Since you’re working with an embedded system, you might need to cross-compile this library for your target architecture or include it in your Yocto Project recipe if you’re building a custom image.

  3. Customize the Build: If you’re using Yocto Project for your image creation, ensure that your local configuration or layer includes the necessary libraries or disables PCI-related features in net-snmp. You can create a custom recipe that patches the net-snmp configuration to avoid PCI dependencies.

  4. Recompile net-snmp: If modifications to the net-snmp package are necessary to remove PCI dependencies, you may need to recompile it from source with the appropriate configuration flags disabled for PCI support.

  5. Check for Alternatives: If the issue persists and PCI support is not critical for your SNMP needs, consider using an alternative SNMP daemon that does not require PCI libraries or has easier configuration options to disable such dependencies.

  6. Debugging and Logs: Review the system and application logs for more detailed error messages that might offer additional clues. Running net-snmp with increased verbosity or debug options might also shed light on the specific PCI-related issues it’s encountering.

Remember, when making changes to the system or software packages, it’s advisable to back up important data and configurations to avoid any potential loss.

Best regards,
Toradex AI Assistant

Please, also check if these links can help you solve your problem:

Colibri iMX7 | Toradex Developer Center.

how to install SNMP daemon in imx7D i tried this it was showing error
opkg install SNMP-Daemon
and i am new to this field

Hi @surya11 ,

Please go through this article to understand image customization using Yocto.
You can check for recipes here and include them in your image.
eg.
IMAGE_INSTALL_append=" net-snmp" (if using dunfell branch)
IMAGE_INSTALL:append = " net-snmp" (if using kirkstone branch).
Let us know if you still face any error.

Hi @surya11,
For testing purpose, I have compiled an image which included snmp packages. Please download it from here
Here is the output observed

root@colibri-imx7-emmc-06372321:~# systemctl status snmpd.service                                                                                                                                                                      
* snmpd.service - Simple Network Management Protocol (SNMP) Daemon.
     Loaded: loaded (/lib/systemd/system/snmpd.service; enabled; vendor preset: enabled)
     Active: active (running) since Sun 2020-09-20 10:44:06 UTC; 3 years 9 months ago
   Main PID: 548 (snmpd)
     CGroup: /system.slice/snmpd.service
             `-548 /usr/sbin/snmpd -Ls0-6d -a -f

Sep 20 10:44:05 colibri-imx7-emmc-06372321 systemd[1]: Starting Simple Network Management Protocol (SNMP) Daemon..>
Sep 20 10:44:05 colibri-imx7-emmc-06372321 snmpd[548]: pcilib: Cannot open /proc/bus/pci
Sep 20 10:44:06 colibri-imx7-emmc-06372321 systemd[1]: Started Simple Network Management Protocol (SNMP) Daemon..

still the error is there cannot open /proc/bus/pci it was making issue while dumping the code into the board

Hi @surya11 ,
You can ignore that message for now and proceed for testing.
You can see that the snmpd is active and running.
Possible reason for this could be that it looks for all possible network interfaces. SImilar post mentioned here

Also, I request you not to create multiple threads of the same issue.

snmpd is running that is fine but i cannot access in mibbrowser


it was showing like this

Hi @surya11 ,
Please use Toradex Easy Installer version 5. The image is compiled for Colibri iMX7D 1GB variant with dunfell branch.

i am getting an issue that it was taking 2mins 35secs to active the snmp

Hi @surya11 ,
Can you please explain the issue properly?
Are you able to install image ?
Is your snmp package issue solved now?
Is snmp server running now?

let me explain briefly with one board i tried stable image and i am getting the issue of 2mins35 secs

in second i created one image by using IMAGE_INSTALL:append=“net-snmp”
i am able to access mib browser but iam not able to communicate the through serial devices in it

while downloading upstream image from installer also my snmp working fine but iam unable to communicate through serial ports can u tell me y

in third i created one image by adding IMAGE_INSTALL:append=“net-snmp”
IMAGE_INSTALL:append=“net-snmp-server” in it timing issue was solved but it was not showing any data in mib browser through we observed serial communication in oscillloscope , data was not showing in toradex

Hi @surya11 ,
The image provided to you is already having the packages required(net-snmp & net-snmp-server).
We can conclude that the below issue is solved

  1. snmp package issue .
  2. snmp server seems to be running now without delay.
    However, I am unable to understand the below lines

What serial communication are you talking about?
Do you mean UART_A debug port?

snmp package issue not solved
yes iam talking about the uart communication
snmp is not running
opkg command was not talking in the created image

Hi @surya11 ,
Taking reference from our previous mails, I have already provided you the image having the required snmp packages and also shared the screenshot of snmp running on Colibri iMX7D.
You also confirmed the same as below

Related to the serial port, please check here.