Downgrading TorizonCore


I have installed TorizonCore 6.3 through Toradex Easy Installer on iMX8QM on Ixora Board. Now, I want to downgrade to TorizonCore 5.7. Since the Toradex Easy Installer is removed after successful installation, I cannot use the same approach. I could not find any articles about this.

What would be the approach and steps to downgrade in my case?

Thank you in advance.

Hello @hajili ,
From this article in the developer webpage:

  • If your module already has an Operating System flashed: If your module already have an Operating System and you want to install another OS, you can download an Easy Installer image and load Toradex Easy Installer into the module’s RAM through a host computer over USB OTG. See the Load Toradex Easy Installer article for instructions.

You can put your board in recovery mode, as explained here:

That will put Toradex Easy Installer in RAM, and then install another compatible version of TorizonCore, reference image or custom build.

Best regards,

Hello Josep,

thank you for the articles provided.

I am trying “Apalis iMX8 5.7.3+build.17 2023/07/27 47.98 MiB”

It stuck here every time:

I have IMX8QM on Ixora Carier board V1.2

Thank you

Hello @hajili ,
Can you share the full name and version of the module that you have , as well as the version of Toradex Easy Installer that you are using?

Best regards,


Software summary
Bootloader:               U-Boot
Kernel version:           5.15.77-6.3.0+git.ddc6ca4d76ea #1-TorizonCore SMP PREEMPT Thu Jun 29 10:14:22 UTC 2023
Kernel command line:      pci=nomsi root=LABEL=otaroot rootfstype=ext4 quiet logo.nologo vt.global_cursor_default=0 plymouth.ignore-serial-consoles splash fbcon=map:3 ostree=/ostree/boot.1/torizon/a35adf7c0791bd73cbf45f441fd426b59e56042b2c34afc06b3615bfd56b5e83/0
Distro name:              NAME="TorizonCore"
Distro version:           VERSION_ID=6.3.0-build.4
Hostname:                 apalis-imx8-07278691

Hardware info
HW model:                 Toradex Apalis iMX8QM V1.1 on Apalis Evaluation Board
Toradex version:          0037 V1.1E
Serial number:            07278691
Processor arch:           aarch64

I am trying to install Toradex Easy Installer - Apalis iMX8 5.7.3+build.17 2023/07/27 47.98 MiB

Anything else I can provide?


Hello @hajili,

One way to downgrade the OS would be through the recovery mode procedure (where you will put the module in recovery mode, flash Toradex Easy Installer, and then install the image version that you want from the feeds). However, since you have TorizonCore, you could simplify this whole procedure of upgrading/downgrading your device through the Torizon Platform. I would highly recommend you take a look at it.

The Toradex Quickstart guide walks you through some of the basic features of the platform such as how to provision your device on the platform, deploying remote OS and Application updates, fleet management, etc. You will find more about how to do the remote OS update here: Updating the Operating System with Torizon Platform Services | Toradex Developer Center

In the meantime, I will try with your HW versions to see if I can reproduce the issue with the recovery mode procedure. I’ll keep you posted.

Hello again @hajili,

So I tried to reproduce this issue with the flashing of the easy installer getting stuck on the Apalis iMX8QM V1.1E module (I have a Linux PC, unfortunately, don’t have a windows PC here). For me, it just worked fine. Could you please connect to the serial console before you run the recovery script and see if it finishes the flashing of the easy installer? This will help to see if the script has actually been executed successfully.
On successful installation on Toradex Easy Installer, it should print out the following (as you see in the image below) on the serial console:

Hello @rudhi.tx ,

Thank you for your recommendations.

I tried connecting the serial console and saw the USB init is failing for some reason.

I am connecting through the X9 port.

I will try the other approach and let you know.

I tried this version: as in the thread of Easy Installer usb init failed - #6 by pally.

I was able to install the Toradex Easy Installer.

Thank you for the help.
Best regards,