Dektop.ini icon

I’m trying to have desktop without any icons on a startup. I was able to delete My Device and Thrash Bin because there were in a register. There’s still desktop.ini and I can’t find the way to delete it too.

Thank you in advance.

Colibri iMX6S 256MB V1.1B
WEC2013 v1.8

I conducted a quick test:

  • Installed a fresh WEC2013 v1.8 version using the Toradex Easy Installer.
  • Removed all entries from [HKLM\Explorer\Desktop].
  • Disabled the background picture using the Background tab in Display properties.
  • Saved the registry.
  • Rebooted.

Result: No icons, including desktop.ini, were present

You can also disable the explorer

That’s strange. I’ve checked another module and in fact there is no desktop.ini either even without disabling background as I need background picture. On my module the copy of it appears in almost all folders after startup.

I’ve found another topic with similar issue Registry save FAILED! message after updating bootload and flash but there is no direct solution. I hope that fresh install would solve that.

Also I would like to know if there’s a way to hide taskbar completely besides disabling the explorer. Auto hide option leaves thin line on the bottom of the desktop.

You can either enable a full screen mode for your application or hide task bar using code listed below. I’ve tested it with WinCE 6 and didn’t check if it works under WEC2013

void ShowHideTaskbar(bool show)
HWND hTaskBar = FindWindow(TEXT(“HHTaskBar”), NULL);
if (hTaskBar)
ShowWindow(hTaskBar, show ? SW_SHOW : SW_HIDE);
// Optionally, update the window to reflect the change immediately

Hi @MES ,

The mystery about the desktop.ini is very simple. This file is always there, but if you set the File Options in the Explorer to not show hidden files it will not be visible as it’s a hidden file. :slight_smile:
I guess one module had a different settings (or different image version where the default setting is different)

I am using that commands inside my application and it’s working great. I have a problem with that lightblue line on the bottom before my application starts. Auto hide doesn’t hide it completely.

Enabling “Do not show hidden files and folders” in fact helped with that desktop.ini icon.
Thank you Germano!

Hi @MES ,

AutoHide is meant to save Space for applications but you need a minimum height so that it’s raised up when someone hover over it.
If you want to completely disable Explorer, why you don’t just prevent it from loading?
Edit following registry entry:
change it to something invalid like “_explorer.exe” so it’s not loaded but it’s easy to revert.
You can reload explorer.exe from your application if/when you need it

Ultimately I was going to do that. I was just curious is there any other way. In that case I will open up explorer from my application and all my problems are solved.

Thank you for your help Alex and Germano!