Debugging of any template fails

Dear Support team,

I am trying in vain to test the templates you have provided for the new Torizon 6… . I set up the development environment with VSCode as you described on the website and everything seems to be working. However, as soon as I switch to “Torizon ARMv7” I get the following error message at:

Executing task: sshpass -p ssh123456789 ssh -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no torizon@ LOCAL_REGISTRY= TAG=arm docker-compose pull test-net-console-debug
Warning: Permanently added ‘’ (ED25519) to the list of known hosts.
time=“2023-06-15T11:48:23Z” level=warning msg=“The "DOCKER_LOGIN" variable is not set. Defaulting to a blank string.”
test-net-console-debug Pulling
test-net-console-debug Warning
WARNING: Some service image(s) must be built from source by running:
docker compose build %s test-net-console-debug
1 error occurred:
* Error response from daemon: Get “”: dial tcp connect: no route to host * The terminal process “sshpass ‘-p’, ‘ssh123456789’, ‘ssh’, ‘-o’, ‘UserKnownHostsFile=/dev/null’, ‘-o’, ‘StrictHostKeyChecking=no’, ‘torizon@’, ‘LOCAL_REGISTRY= TAG=arm docker-compose pull test-net-console-debug’” terminated with exit code: 18.

I tested that with Python 3-, .NET 6 C# Console Application- and ASP.NET 6 Blazor Application-Templates. Debugging stops allways with simular error code.
Do you have an idea, what I did wrong? Thanks in advance.

Apalis imx6 V1.1B
Ixora V1.1A
Torizon 6.2.0
VSCode 1.79.1
WSL2 → Ubuntu 22.04
ApolloX V2.0.0

I also have another question. When I start debug, all existing containers on device get stoped and removed. When working with Torizon 5 and Torizon extension V1, this behavior was not present. Can I set up this anywhere?

Hello @JanP,

Thanks for reaching out to the Toradex Community!

Since you said it worked just fine with IDE extension V1 and now it has issues on V2, it really looks like a conflict between the two versions installed on VSCode.

Please take a look at this answer from @lucas_a.tx on a similar topic.
In summary, if you are trying to use V2, you must make sure that you have disabled V1 of the extension. Please let me know if that helps :slight_smile:

Hello @rudhi.tx ,

Thanks a lot. I found the problem. I was connected to the company via VPN and then, I don´t know why, but Ubuntu distro became an IP from the wrong ethernet adapter. After disconnecting VPN and restarting the my mashine, everything works fine.

But one thing more to my second question: When starting debugging all other running containers will stopped and removed. Can you change that behavior?

Hi @JanP !

Nice! Thanks for the feedback :slight_smile:

Do you have more than one container? Could you please share a bit of your “container architecture”?

Best regards,

Hi @henrique.tx,

No. I used the preinstalled standard templates from the ApolloX extension as single project and changed under Run and debug to “Torizon ARMv7” and pressed F5 without any changes. During deploy process this will shown in Termin.

Same thing happens on the pc of my college.

Hi @JanP !

Sorry, I didn’t quite understand your last message. Did some issue happen?

Could you give us some context?

Best regards,

Hi @henrique.tx ,

No problem. So again:
When I start debugging, all running containers on my iMX6 seems to be stopped and removed during deploy process (like you see in the screen shot from terminal output).
My question is: Can I change that behavior and if so, where to do that?

I don´t use multi container. I just create a new single container project (e.g. blazor-template, c#-console-template or c+±template). I did no changes at the projects. I just changed to “Torizon ARMv7” and start with F5. At all that three templates happens the same. Running containers get stopped and removed.

Deployment and debugging is working fine. There is no issue happen.

Hi @JanP !

Thanks for the explanation!

This is indeed the expected behavior. Torizon extension will stop the containers currently running on the target and remove them before launching the container(s) of your project.

If you want to have some containers running during your tests/debugging sessions, you will need to adapt the docker-compose.yaml of your project by adding those containers in there.

Be aware that a breakpoint during your debug session will only pause the application that you are developing. The other container/applications of your architecture will not be paused (just like any usual debugging session :wink: )

At the same time, if this is not suitable for your use case, please share with us your needs. I can bring up your specific use case internally in Toradex to be analyzed :slight_smile:

Best regards,

Thanks a lot @henrique.tx!

I understand! Do you have an example how the construction of .yaml-file looks like, when I want that the default and preinstalled portainer backend funktionality is available during debugging?

Hi @JanP

Glad to help :slight_smile:

Toradex has this nice repository with several examples: GitHub - toradex/torizon-samples: All sample code related to TorizonCore project.

In there, you will find e.g. the debian-container folder that holds something similar to what you have by default when you install TorizonCore with Evaluation containers. Please pay attention to the branch and the file that you will use as the reference for you. The link below is on the bookworm branch (the current version of Debian used in TorizonCore 6 containers) branch and is meant for Arm 32-bit modules with GPU (like your Apalis iMX6).

Best regards,

Thanks a lot @henrique.tx !

1 Like

You are welcome, @JanP !

If your question/issue was solved, please don’t forget to mark the most suitable message as the solution :wink:

Best regards,