Colibri IMX8 Ethernet not working except in recovery mode


I had to reflash a board as the network configuration was a little wrong and it wouldn’t connect to any networks. It would start up occasionally with lights on the RJ45 on the carrier board, but then they would go out and the connected device would just say cable unplugged.

After flashing it the ethernet port has the orange light permanently on dim. If I put it in recovery mode and run the script it does connect to the internet and is able to see available images online with the vnc viewer, with the lights working just fine.

I thought there might be lingering settings so I cleared the flash before getting a fresh image and it still ended up in the same state.

Does recovery mode have a different Ethernet interface? Could the issue be hardware?

Board: Colibri IMX8QXP 2GB with a Viola Rev 1.2 Carrier Board

Thank you

Toradex Easy Installer is stripped down version of Linux with a GUI application . So It’s not a HW issue. Something wrong with your SW settings. Could you please provide details about Image you are using and its revision (For example Linux Reference Minimal Mainline based kernel Wayland/XWayland graphics back-end supported but not included
5.7.2+build.21 )

I have tried minimal image without graphical interface that just boots (5.7.2+build.21)

Hello @sreed ,
Can you please share with us the boot log of your board and your network configuration?

Best regards,

I would, but I’m afraid the only way I have of accessing the board is through Ethernet (which isn’t working). I have tried serial comms and a USB to Ethernet adapter, but was unable to get any information output it.
Currently the network config is directly to a switch with a router on the network, but I’ve also tried connecting directly to my linux computer and received nothing from the board when I ran tcpdump.

Hello @sreed ,

Regarding this new issue, have you followed the steps described here?

Best regards,

Yes, those are the ones I used to try and get serial comms, but we use the serial interface so I am pretty sure it is disabled and that is why we get no output. Does this change with a new image flashed onto it?

Hello @sreed ,
The serial port should be enabled, regardless of the image.
Could you please

  • explain how you power the board
  • send us a picture of your setup, with all the connected cables.
  • share with us the data sheet of the USB to serial cable that you use

Best regards,

Powering the Board:

We power it with a power distribution board with a bench supply straight into the X9 header


Not a picture, but I can give you a diagram (might be easier to follow):

Serial Cable

The serial cable is this one

The Viola carrier board does not have RS232 interface. You should use UART TTL to USB adapter instead of USB to RS232 converter. Please follow this article.

Thank you, will give it a try and get back to you


Sorry for the delay,
I bought a new serial cable and tried it out. On boot I only managed to get the symbol �
through the serial connection.
I tried putting it into recovery mode and the serial comms work perfectly (see below). I then flashed it with the same image as it’s using in recovery and I get the same result (�).

U-Boot 2018.03-toradex_imx_v2018.03_4.14.98_2.3.0_bringup+g9393e0c9bd (May 19 2020 - 21:36:48 +0000)

CPU:   Freescale i.MX8QXP revB A35 at 1200 MHz at 47C
DRAM:  2 GiB
PMIC:  device id: 0x40, revision id: 0x31, emrev 0, prog id fff
Loading Environment from MMC... OK
In:    serial
Out:   serial
Err:   serial
Model: Toradex Colibri iMX8 QuadXPlus 2GB Wi-Fi / BT IT V1.0B, Serial# 06614389

  - SCFW b929edfe, SECO-FW f449a0d2, IMX-MKIMAGE d7f9440d, ATF bb209a0
  - U-Boot 2018.03-toradex_imx_v2018.03_4.14.98_2.3.0_bringup+g9393e0c9bd 

Detect USB boot. Will enter fastboot mode!
Net:   eth0: ethernet@5b040000 [PRIME]
Fastboot: Normal
Boot from USB for mfgtools
Use default environment for                              mfgtools
Run bootcmd_mfg: fastboot 0
Hit any key to stop autoboot:  0 
Detect USB boot. Will enter fastboot mode!
Starting download of 2246 bytes

downloading of 2246 bytes finished
Detect USB boot. Will enter fastboot mode!
Starting download of 37580888 bytes
downloading of 37580888 bytes finished
## Executing script at 82e00000
## Loading kernel from FIT Image at 83000000 ...
   Using 'config@freescale_fsl-imx8qxp-colibri-eval-v3.dtb' configuration
   Trying 'kernel@1' kernel subimage
     Description:  Linux kernel
     Type:         Kernel Image
     Compression:  gzip compressed
     Data Start:   0x8300010c
     Data Size:    6689667 Bytes = 6.4 MiB
     Architecture: AArch64
     OS:           Linux
     Load Address: 0x80280000
     Entry Point:  0x80280000
     Hash algo:    sha1
     Hash value:   e603347e704540f0cba4ebd55770bf5f8f862fbc
   Verifying Hash Integrity ... sha1+ OK
## Loading ramdisk from FIT Image at 83000000 ...
   Using 'config@freescale_fsl-imx8qxp-colibri-eval-v3.dtb' configuration
   Trying 'ramdisk@1' ramdisk subimage
     Description:  tezi-initramfs
     Type:         RAMDisk Image
     Compression:  uncompressed
     Data Start:   0x836c86bc
     Data Size:    30466048 Bytes = 29.1 MiB
     Architecture: AArch64
     OS:           Linux
     Load Address: 0xa0000000
     Entry Point:  unavailable
     Hash algo:    sha1
     Hash value:   d00ffa50e8c8da4bae941b4d5a774a6f7b25fb28
   Verifying Hash Integrity ... sha1+ OK
   Loading ramdisk from 0x836c86bc to 0xa0000000
## Loading fdt from FIT Image at 83000000 ...
   Using 'config@freescale_fsl-imx8qxp-colibri-eval-v3.dtb' configuration
   Trying 'fdt@freescale_fsl-imx8qxp-colibri-eval-v3.dtb' fdt subimage
     Description:  Flattened Device Tree blob
     Type:         Flat Device Tree
     Compression:  uncompressed
     Data Start:   0x836615b0
     Data Size:    84042 Bytes = 82.1 KiB
     Architecture: AArch64
     Hash algo:    sha1
     Hash value:   5075a816962b48701bdee4ded29c65b247579a06
   Verifying Hash Integrity ... sha1+ OK
   Booting using the fdt blob at 0x836615b0
   Uncompressing Kernel Image ... OK
   Loading Device Tree to 00000000fd663000, end 00000000fd67a849 ... OK
/dma-controller@591F0000, 64852
/dma-controller@599F0000, 65816
/dma-controller@5a1f0000, 63900
/dma-controller@5a1f0000, 63900

Starting kernel ...

[    0.352311] dmi: Firmware registration failed.
[    0.776174] Can't support > 32 bit dma.
Running /etc/rc.local...
Starting udev
System time was Tue May  9 10:02:13 UTC 2023.
Setting the System Clock using the Hardware Clock as reference...
System Clock set. System local time is now Tue May  9 10:02:13 UTC 2023.

Welcome to the Toradex Easy Installer

This is a Linux based installer for Toradex modules. Currently, the installer
does not have a serial console interface. You can use the Toradex Easy Installer
via any of the available display interfaces using USB mouse/keyboard or via a
network connection using VNC. Use:
  # ip addr show eth0
to display the Ethernet IP address or use USB RNDIS at IP

Check our documentation at:

It seems like it doesn’t actually boot outside of recovery, so I’m guessing when it’s flashed somethings not pointing to the right location? I have tried this on a different board with a different laptop which has ended in the same result.

Thank you,

Hello @sreed,

have you tried flashing our reference image? or TEZi itself?

The Image that you are trying to flash, is a custom image build with our BSP?

Best Regards,


Hi Matthias,

I have tried flashing the minimal image and TEZi from online,


Hello @sreed,

Sorry about the delay in answering.

I see from your boot log that you are trying to boot an image (probably your custom image?) from a USB. Could you please try the following:

  1. Put the module into recovery and flash Toradex Easy Installer. Please use the latest version of the easy installer ( 5.7.2+build.14) for your colibri iMX8X module which you can download here.
  2. Install one of our Yocto reference images (I recommend the BSP 6) which you will find listed on the feeds.
  3. Send us the boot log

Hello @sreed,

Hope you are doing well. May I know if have any updates on this topic?


We are going to try boards with a display instead,

Thank you,

Hello @sreed,

Sure, please let me know how that goes. If you would still like to troubleshoot the issue on the Viola board, I would propose an online meeting for about half an hour. Please let me know if you’d like that.