Colibri imx6 wince 7 USB stick doesn't work

Good afternoon, on one of our dome hardware we first mounted your colibri tegra card and now we mount your colibri imx6 card with wince 7 ver 1.5 the USB stick is not detected. for what reason? Are we doing something wrong or is there some setting to do?
Thank you

The Colibri iMX6 module operating with Windows CE 7 should automatically recognize a USB stick without any additional configuration. Could you please provide more details about your situation?

  • Which carrier board are you using?
  • What is the exact Colibri module you are using, including its hardware revision?
  • Does this issue occur with a specific USB stick, or do all USB sticks fail to work?
  • Have you tried the latest version (1.8) of the OS release?

good morning, I use the colibri evaluation board rev 2.1 01/2006, then I also use our board which deviates from the one described above not only two USB ports 1 host 1 device.

the colibri module is iMX6DL 512MB V1.1B 15053208.

the problem occurs with all types of USB sticks, I don’t see any, but the mouse and keyboard work. I tried with version 1.8 but nothing changes.

Thank you

Sandro Tecchio

Is your issue reproducible on the Colibri Evaluation board, or is it only on your custom board?

the problem also occurs on the colibri evaluation sheet. It only works as a keyboard and mouse

Unfortunately, I can’t reproduce your issue. I used a fresh Colibri iMX6DL 512MB V1.1B module and flashed it with WinCE7 version 1.8. When using the Colibri Development Board v3.2B, I was able to successfully mount every USB stick I tried.
How did you check USB stick detection ?

sorry but the USB stick doesn’t start automatically in my device? Do I have to do any assembly procedures?

because with the colibri tegra t20 card when I insert the USB stick I see it in mydevice

Could you please clarify what you mean by ‘automatic start’? Also, could you specify which ‘assembly procedure’ you are referring to?

I observed the same behavior on the Colibri iMX6.

in reference to the Colibri Development Board v3.2B, which connector do you insert the USB stick into? x?
Thank you

because in the evaluation board that I have, I only have the two USB ports managed by pins 139-141 and 143-145 of the colibri imx6, perhaps the USB stick doesn’t work on these ports. Thank you

Any slot on the X31 or X32 connectors.

Are we talking about same Colibri Evaluation boards? The Colibri Evaluation Board v2.3B features an onboard USB hub with four USB ports. The USB hub itself is connected as a device to the Colibri pins 139 and 141. And Colibri pins 143 and 145 are connected to USB Client connectors on the Colibri Evaluation boards .

good morning, I tried with the colibri evaluation board rev 2.1 01/2006, no USB stick works on the USB port that goes to pins 139-141 and 143-145 of the colibri module. Only the keyboard and mouse work for me. thank you for the help.

Hi @sandro ,

If i understand it right you say that by only exchanging T20 with iMX6 Module makes the USB Stick work/not work.
There are a few possible reasons here:
Different Registry settings on T20 and iMX6 Module (try erasing registry on both to see it they then behave the same)
Uncompliant USB Stick. Did you try with differnet ones?
Defective iMX6 Module. Did you try different ones? (USB Keyboard and Mouse are low speed USB so it could be that they still work, but USB Stick is HighSpeed USB and could be failing if there is a problem with the Module)

Hi, I tried with multiple imx6 modules and they have the same problem. I also tried with various types of USB sticks, they are not detected. I have now ordered the new colibri evaluation board to see if there are any differences.

Could you please confirm whether the Green LEDs (LED7-LED10) are lit when the OS has booted?

Hi @sandro ,

I did not realize immediately that you tested it only on the old evaluation board 2.x !
The old evaluation board (the one with only 2 USB ports) is not USB Highspeed compatible.
In order to be able to use it you have to force the iMX6 to use only FullSpeed instead of trying Highspeed.
This explains why only LowSpeed devices like Mouse and Keyboard work.
But it does not explain why it was working with T20 module. But maybe you did the HighSpeed=0 USB registry setting there already?
On iMX6 the reg settings are to be put in:

Hi @germano there isn’t this key in regedit, where should I create it? Thank you