Colibri imx6 wince 7 USB stick doesn't work

Hi @germano, I tried to insert these keys that I found on the Toradex site, but the USB stick doesn’t work anyway. Thank you

[HKLM\Drivers\Builtin\HCD_HSH1]
HighSpeed = dword:1 ;default=1 → High Speed (Vybrid BSP V1.1beta2 and higher/IMX6 1.1beta1 or higher)

[HKLM\Drivers\Builtin\HCD_HSH2]
HighSpeed = dword:1 ;default=1 → High Speed (Vybrid BSP V1.1beta2 and higher/IMX6 1.1beta1 or higher)

[HKLM\Drivers\Builtin\USBFN]
HighSpeed = dword:1 ;default=1 → High Speed (Vybrid BSP V1.1beta2 and higher/IMX6 1.1beta1 or higher)

[HKLM\Drivers\Builtin\UsbOt\Hcd]
HighSpeed = dword:1 ;default=1 → High Speed (Vybrid BSP V1.1beta2 and higher/IMX6 1.1beta1 or higher)

[HKLM\Drivers\Builtin\UsbOt\USBFN]
HighSpeed = dword:1 ;default=1 → High Speed (Vybrid BSP V1.1beta2 and higher/IMX6 1.1beta1 or higher)

Hi @sandro ,

you need to set the HighSpeed to 0, not 1.
In your post you write that you set it to 1 which means enabling HighSpeed.
It needs to be disabled in order to work on older non HighSpeed compatible HW.

yes, I set the value to 0, but the USB stick still doesn’t work.

Hi, thanks to your help I found this link on the Toradex site where, after modifying the hardware, the key works. Thank you

Hi @sandro ,

I’m glad you found a solution by patching the HW.
It should also work by forcing the Highspeed=0, not sure why it does not work for you.
Anyway it’s for sure better if you can patch the HW so you can take advantage of the HighSpeed transfers.