C/C++ Development and Debugging on TorizonCore Using Visual Studio Code


1.) Problems Tab: Cannot find aarch64-linux-gnu-gcc
2.) Message Box: launch property ‘program’ is missing or empty in ‘launch.json’
How to solve ?

Greetings @RJKuenzi,

What OS are you running VSCode on and what version of our VSCode extension do you have installed?

Looking at the error messages you provided it seems the ARM64 compiler can’t be found. Which is odd since this should be in the SDK container that the extension creates when you open a C/C++ project. Perhaps there was an errors with the SDK container or some kind of configuration issue.

Can you reliably reproduce this? For example if you create a brand new fresh C/C++ project does this issue occur again?

Finally can you just double-check that all the prerequisites for the extension were met: Visual Studio Code Extension for Torizon | Toradex Developer Center

Including everything in the Build Environment for Torizon Containers article.

Best Regards,

Ubuntu 18.04 LTS
Visual Studio Code 1.58.2
Toradex Torizon Support 1.3.0
Docker version 20.10.7 build b0f5bc3
See attached notes and Images.
RJKuenzi_10282021.zip (846.2 KB)

Thank you for the tests and additional information.

Hmm I mean so it seems like everything worked just fine. The container built and debugged just fine. The Cannot find aarch64-linux-gnu-gcc in the problems tab is just a warning that can be ignored.

Did you actually experience any blocking errors in the extension? Or did I misunderstand your original post?

Best Regards,

I always get #1 since day 1 and still have that, but there is no problem compiling the code.

#2, I found the vscode/extension sometime got messed up. and it helps fixing by doing Developer: Reload window, or restart vscode (sometimes need to do a few times).

Hi @swc,

I’ve never personally encountered issue #2, at least not recently. Do you know of a method to reliably reproduce this?

Also is this on the stable or early access version of the extension?

Best Regards,

no, I don’t know how it happens.
I’m using early access version.
I have a wild guess, maybe it is when the extension version changed caused it sometimes?
the last one automatically updated the extension and caused my code to fail on open any devices(i2c, usb,etc…). and when I restart vscode I realized the version updated and I had to rebuild the sdk in order to fix it.

I had previous experience, it can’t run(or compile) and then complains about the .json file.

and it happen(can’t say it’s the ‘program’, but its the .json file) when a folder(project) haven’t been touch for a long time and it no longer can compile due to container related problems. and that it ‘lost’ the extension is not installed for that project. sometime, it’s lucky, just click the install in … button and works. but sometimes had to go thru restart, rebuild sdk, reload window or a combination of these to get it back.

I just opened the folder/project from last Friday and I saw the extension say reload required.
last Friday, everything was working. it is still working.
after I reload, now I’m getting error.


and retry don’t work. have to Open … locally.
after that, popup say "remote-container… " forgot the exact command.
now all my open failed with -4(no devices) again

did a “developer: reload window” and the ‘program’ error comes up when I try to run.
run again, no ‘program’ error, but the open calls still fail.
rebuild project, still fails on open calls.
doing “Torizon: rebuild sdk and reload container”
clean project and run still doesn’t work. :frowning:

looked at the extension again and find docker is not install in the container

install it, and clean project and run, still don’t work.

I think I know the #2 issue. I notice this before. when you start VSCode, make sure to wait for the Torizon extension to load and initialization to finish (lower right pops), otherwise, that issue pops up.
it takes a while(more than a few second)
recently I don’t restart vscode, so I haven’t seen it.
but with this open call fail again, I’ve been trying to restart vscode and I saw that again and realize it.

another instance #2 issue happens.
now, I tried to open an old folder/project because I’m still having this open calls issue.
and this #2 issue happens,(even I waited for the torizon extension to load an init to finish)
I noticed the extension need to be install.

after this is installed, the #2 issue is gone.
so this is another instance that seems to trigger that.

sorry to hijack the thread.
I had go back to version v1.4.158 to make my open calls work again.
260, 261 didn’t work.
but my colleague said 261 version work for him. strange.

@swc Thank you for all the information. Seems like this is a really strange issue/bug. Let me report it to our extensions team and see if they have an idea of what could be causing this.

In the meantime please feel free to add any more information you uncover.

Best Regards,

What’s the conclusion, I’ve the same problem with Visual Studio Code 1.67.0 and latest Torizon version and Veridin imx8mp


Hi @JanuszK,

Could you please open another thread describing your issue. The issue in this thread was never resolved since we were never able the reproduce it and the original customers never got back to us. Therefore we were unable to determine whether there was actually an issue or not.

Best Regards,