Apalix IMX8QM/Ixora V1.2 random reset

Hello everyone,

I have a strange issue, I have an Apalix IMX8 QuadMax 4GB mounted on an Ixora V1.2 running TorizonCore with pre-evaluation containers, sometimes the board restarts randomly with no warnings or anything, this happened multiple times now at different scenarios ( standing by, running a container, etc) , I can’t seem to reproduce it intentionally.

should we turn of the default running containers to avoid this (Ex. portainer) ?

any idea how to tackle this ?


Hi @AhmedMobarez, how are you?

Can you confirm with version of the TorizonCore image are you using? Is this the PREEMPT-RT? You can obtain the version with: cat /etc/os-release.

Does this happen with only one module or more?

Have you added other containers?

Did you do any image customization?

Best regards,

Hello @gclaudino.tx ,

This is the OS release

apalis-imx8-07107575:~$ cat /etc/os-release
NAME="TorizonCore with PREEMPT_RT"
VERSION="5.6.0+build.13 (dunfell)"
PRETTY_NAME="TorizonCore with PREEMPT_RT 5.6.0+build.13 (dunfell)"

we added only the qt5 wayland container from toradex here

and we add a few libraries in the docker file that are required for our Qt application, I could share the Dockerfile with you if needed.

Also we have two Apalis modules and two ixora boards, this is happening with only one of them.

Small update #1

it happened again so I added the device to the torizon platform for monitoring, but the metrics were not being loaded, so I initiated an update ( same OS version as above), after that the metrics are loaded normally and I have been running the device for ~2 hrs with no issues, I will leave it for a couple more hours for monitoring, let me know what you think


Hi @AhmedMobarez,

Thanks for the update. There is a known issue with the PREEMPT_RT image that causes the iMX8QM modules to reboot at random times that we’re working on. Would it be a possibility for you to use the image without PREEMPT_RT and check if the reboot also happens there?

Please keep us updated about your tests :smiley:

Best regards,

Hello @gclaudino.tx ,

So I have left the board running over the weekend, no restarts and works normally. not sure why since it was the same exact version I downloaded using the toradex easy installer.
However, since this is a known issue I will just deploy the image without PREEMPT_RT till it works. thanks for the support

Hi @AhmedMobarez,

Thanks for the update. We’ll come back to you once we have any news on the PREEMPT_RT topic, I hope I can have an answer shortly. Can we tag this ticket as solved for the moment as the other image works?

Best regards,

Sure, for me it’s solved, thanks a lot :slight_smile: