10.1 inch capacitive touch screen not functional

Hello everyone, I recently got and Apalis IMX8 quadmax with wifi and BT along with Ixora V1.2, we also got the 10.1 inch capacitive touch screen with the LVDS connector.

I originally thought it was plug and play, but after talking to the support I realized I have to adjust the overlays.

Using the VS studio code and toradex plugin, I was able to access the module and change the overlay.txt , the following is the terminal output and current contents of the file:

" apalis-imx8-07107575:/sysroot/boot/ostree/torizon-7c4c05bc34d4f4af22b2cea64f9e588******************/dtb$ cat overlays.txt

fdt_overlays=display-lt170410_overlay.dtbo apalis-imx8_atmel-mxt_overlay.dtbo apalis-imx8x_lvds_overlay.dtbo "

according to my understanding, I now disabled the HDMI overlay and enabled the lvds overlay according to this page Setting up Displays with Torizon | Toradex Developer Center :

The screen still doesn’t work after this change, and also the hdmi is disabled, if I reverse the change and include only the hdmi overlay I can use the hdmi output again.

The current toizon core version I am using:
dunfell/apalis-imx8/torizon-rt/torizon-core-docker/release
Version: 5.6.0+build.13

is it because I have the latest version and in the above referenced page it mentions the kernel : toradex_5.4-2.3.x-imx ?

Reference images for hardware connections :


Please advise

Hi @AhmedMobarez ,

In your overlays.txt:

  • There is an entry named apalis-imx8x_lvds_overlay.dtbo (notice the x after 8) which does not apply to the Apalis iMX8. I think you meant apalis-imx8_lvds_overlay.dtbo.

  • While you referenced all the correct .dtbo files (considering the correction above), the order in which you write them matters, as each overlay file is applied sequentially. So the content of your overlay.txt should be:

fdt_overlays=apalis-imx8_lvds_overlay.dtbo apalis-imx8_atmel-mxt_overlay.dtbo display-lt170410_overlay.dtbo

toradex_5.4-2.3.x-imx refers to the Downstream Linux Kernel from NXP and it is the default version used in TorizonCore for our iMX8/iMX8X modules, while toradex_5.4.y refers to the Upstream Kernel, being the default version in TorizonCore for our iMX6 and iMX7 modules.

So the TorizonCore version that you’ve installed for Apalis iMX8 is using toradex_5.4-2.3.x-imx already, no need to worry about this.

And lastly, your hardware connections seem to be correct. Try changing overlays.txt and see if that solves your issue.

Best regards,
Lucas Akira

Thanks a lot, this solved the issue

Glad I could help!

Best regards,
Lucas Akira