YOCTO recipe copy application dependancies

I have created a recipe to copy my application into my image to install on my product.
When i set it to copy a file such as an image it builds fine.
When i set it to copy an application then it complains that the libraries the application was built with are not provided

I have tried adding DEPENDS but still not joy

this is the recipe

Package summary

SUMMARY = “add folders”

License, for example MIT


License checksum file is always required

LIC_FILES_CHKSUM = “file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302”

MY_FILES = “/home/adrian/filestocopy”

S = “${WORKDIR}”

do_install () {
install -d ${D}/home/root/
install ${MY_FILES}/adrian.png ${D}/home/root/
install -m 0755 ${MY_FILES}/myapp ${D}/home/root/

FILES:${PN} += "

I know my apps makefile includes

LIBS = -lgpiod -lpng

and when im building my image i get error statements such as

ERROR: addfolders-0.1-r0 do_package_qa: QA Issue: /home/root/myapp contained in package addfolders requires libgpiod.so.2, but no providers found in RDEPENDS:addfolders? [file-rdeps]

How do i get it to accept the libraries that have been installed in the image ?

(Note : If i just try copying the adrian.png then it builds fine and the image includes the image file in the correct location on my device)

Found the solution

Needed to add

RDEPENDS:${PN} = " libgpiod libpng"