Yocto Bitbake Error after i stop one time

Hello,

I am having trouble with bitbake. I used to build without any problem but one time i had to interrupt with CTRL+C and after that i could never build anything again. I tried to delete all files that repo sync(oe-core) and sync again but nothing has changed.

There isnt any problem at repo sync 13/13 succesful. I also download all the prerequirements.

    bitbake tdx-reference-multimedia-image -k
    Summary: 3 tasks failed:
        /home/stg/oe-core/build/../layers/meta-qt5/recipes-qt/qt5/qtbase_git.bb:do_configure
        /home/stg/oe-core/build/../layers/openembedded-core/meta/recipes- 
support/gnutls/gnutls_3.6.14.bb:do_package
       /home/stg/oe-core/build/../layers/meta-openembedded/meta-oe/dynamic-layers/meta-python/recipes-extended/mozjs/mozjs_60.9.0.bb:do_compile
Summary: There were 4 ERROR messages shown, returning a non-zero exit code.

I am adding bitbake-cookerdaemon.log and also FULL console output to attachments.

bitbake-cookerdaemon.log

consoleText.txt

Hi @Engineering_AV,

Which repo branch and manifest are you using for the BSP5/Dunfell from Toradex?

which file i should put here.
Mainly i followed this guide:
https://developer.toradex.com/knowledge-base/board-support-package/openembedded-core#Failing_Builds

@Engineering_AV,

I meant about your Yocto BSP Repo settings, like this here - Building a Reference Image with Yocto Project - First Time Configuration.

Could you please try to do the following:

  • Delete the entire folder you are using with the current Yocto Build (there is a hidden .repo directory that you may have missed before).
  • Create a new folder and follow the process for setting up your Yocto Repo for BSP 5 again.

Please try that and let me know if it worked.

Best regards,
André Curvello