Yavia board not working


I have a Verdin iMXM8M Plus connected to a Yavia carrier board.

The board no longer works. There are 2 red leds on:

  • D21: The module is in the reset state (CTRL_RESET_MOCI is low)
  • D22: DSI to HDMI bridge is in the reset state

I’ve tried to follow the steps to enable the recovery mode as described in the links bellow, but the board is not detected:

I’ve tried to connect to the J5 Debug port using PuTTy, but I could not communicate with the board.

Any idea on how to get the board functional again? Is the board broken?

I’ve attached a photo of the board.

Thank you.

Hi, I’m the Toradex AI Assistant. I’m in early beta, and I would appreciate your feedback.
The Toradex Support team will follow up with you shortly!

Did you like my answer?

:+1: :-1:


Based on the symptoms you’ve described, it seems like the Verdin iMX8M Plus module on your Yavia carrier board is not booting up properly. The fact that you’ve observed D21 and D22 LEDs indicating reset states and your inability to detect the board in recovery mode or communicate via the debug port suggests a deeper issue that might not be resolved through standard recovery procedures.

Given the steps you’ve already attempted, including trying to enter recovery mode and attempting communication through the debug port without success, there are a few additional things you might consider:

  1. Power Supply Check: Ensure that the power supply you’re using meets the requirements for the Verdin iMX8M Plus and the Yavia carrier board. An inadequate power supply can cause the issues you’re experiencing.

  2. Inspect for Physical Damage: Carefully inspect both the Verdin module and the Yavia carrier board for any signs of physical damage. Look for burnt components, damaged pins, or anything out of the ordinary.

  3. Re-seat the Module: If you haven’t already, try re-seating the Verdin module on the Yavia carrier board. It’s possible that the module is not properly connected, causing these issues.

  4. Try a Different Module: If you have access to another Verdin module, try booting the Yavia carrier board with it. This can help determine if the issue lies with the module or the carrier board.

  5. Check for Short Circuits: Use a multimeter to check for any short circuits on the carrier board, especially around the power supply circuitry and the module’s interface connectors.

If after these steps the issue persists and the board remains unresponsive, it might indicate a hardware failure that cannot be resolved through standard troubleshooting steps. In such cases, the hardware might need to be evaluated and possibly repaired or replaced. Given the complexity of embedded systems, diagnosing hardware issues can be challenging without the right tools and expertise.

Best regards,
Toradex AI Assistant

Please, also check if these links can help you solve your problem:

NXP i.MX and TI AM62x Recovery Mode | Toradex Developer Center.

As I have 2 boards and 2 carriers, I’ve tried swapping them.

These are the results:

iMX8M Plus Board Yavia Carrier Recovery Works Red LEDs
15230141 35610066 D21, D22
15229926 35610040 Y
15230141 35610040 D21, D22, D27
15229926 35610066 D21

Are both the 15230141 board and 35610066 carrier busted?

Hi, can you please provide us with some additional information?

  • What OS version was previously installed in the Verdin iMX8M Plus SoMs?
  • What version of Toradex Easy Installer are you using?
  • What OS are you using in the host machine running the Toradex Easy Installer script?
  • What messages does the recovery script show in the failure cases?
  • Are you using any HDMI display connected to the Yavia board? If yes, can you retry with the HDMI cable disconnected to avoid potential backfeeding?

Meanwhile, I will check what insights we can get from the LED information you provided.

Best regards,
Danilo Viana

Toradex Easy Installer: Verdin-iMX8MP_ToradexEasyInstaller_6.6.0+build.6
Host OS: Windows 11 Pro
Recovery script message: Success 0 Failure 0 Wait for Known USB Device Appear…
Are you using any HDMI display connected to the Yavia board? No

This is from the board that still works. The broken one used the same firmware:

sudo tdx-info

Software summary
Bootloader:               U-Boot
Kernel version:           5.15.129-6.4.0+git.67c3153d20ff #1-TorizonCore SMP PREEMPT Wed Sep 27 12:30:36 UTC 2023
Kernel command line:      root=LABEL=otaroot rootfstype=ext4 quiet logo.nologo vt.global_cursor_default=0 plymouth.ignore-serial-consoles splash fbcon=map:3 ostree=/ostree/boot.1/torizon/9e5c23c91a4a616f1c620898ad97907b845ca4bb1bb12b159d0ec546044561ce/0 clk-imx8mp.mcore_booted=1
Distro name:              NAME="TorizonCore"
Distro version:           VERSION_ID=6.4.0-build.5
Hostname:                 verdin-imx8mp-15229926

Hardware info
HW model:                 Toradex Verdin iMX8M Plus WB on Yavia Board
Toradex version:          0058 V1.1B
Serial number:            15229926
Processor arch:           aarch64

Thanks for the information.

Did you follow the steps described in the recovery-windows.README file inside of the Toradex Easy Installer folder?

Best Regards,

Yes. By swapping the 2 boards and the 2 carriers, I was able to start the Toradex Easy Installer for 1 combination and failed for the other 3 combinations.

We’ve decided to return the defective board and carrier to my manager that has better electronics skills.