Write image from TEZI

I’m not very expert on tezi because an old colleague of mine took care of it.
I have a Yocto image and i want to flash it on my Apalis module so I put the extracted image on a USB pendrive.

I start the board in recovery mode and I launch TEZI (I downloaded the last update one).
When TEZI ask to plug in the USB I do it and I wait.

I get a final feedback on the screen which tell me to reboot the board, so I reboot the board but it does not work.
I can’t see nothing on the screen and also on the console.

I guess something change from

Apalis iMX8QM 4GB WB V1.0B


Apalis iMX8QM 4GB WB IT V1.1B

since doing the same things on V1.0B it works, on V1.1B it doesn’t.

What I’m doing wrong?
Thank you all

An Apalis iMX8QM 4GB WB V1.0B is a sample product and not supported anymore. Looks like your current based based on an old release suitable for v1.0B only . Please rebuild your image using latest updates. See details here.

Hi @alex.tx
I came back on this issue only now since I was working on other projects.
I created a new “workign folder” where I configured the last Toradex release, following the details you sent me.
In this way I can also keep my old workspace where everything was ok.

I moved my meta layer in the new workspace and I tried to compile my recipe.
I’m facing up a problem: during the bitbake the recipes for systemd crash with a very long log.

I took the liberty of attaching it. link text

I’m really sorry but my skills in yocto are very basic.
Can you help me please?

I can’t tell what exactly wrong with your setup. According your error log:

Found ninja-1.10.0 at /home/user/oe-core_5.0/build/tmp/work/aarch64-tdx-linux/systemd/1_244.5-r0/recipe-sysroot-native/usr/bin/ninja
cp: cannot create regular file '/home/user/oe-core_5.0/build/tmp/work/aarch64-tdx-linux/systemd/1_244.5-r0/git/rules/60-input-id.rules': No such file or directory

So check your permissions and/or layer configuration. If you not familiar with Yocto I’d recommend to start with simple layer like described here.

From other hand if you don’t want to mess with Yocto you can use Torizon. You will be able to start a Debian Container and then use Debian package manager to install any packages you like. Or you can choose any other available containers.

Hi @alex.tx.
I’ll try to check permission and conf.
I need to use Yocto, I’m not very skilled but consider I have already realized different “machine” in the past on imx6 and one on imx8.
The last one (imx8 working on Apalis iMX8QM 4GB WB IT V1.0B) is the machine I’m tryng to move under 5.0 distribution.

I’ll update you in the next days

Hi @alex.tx , apparently I’m stolving the issues step by step.
I hope things are going well since now I’m able to bitbake alla the packages I need form my machine.
I’m able to compile different packages but I can’t get the final image of my machine.
This due to this error:
imx8qm-chelt-mec-1.0-r0 do_rootfs: The postinstall intercept hook ‘update_gtk_immodules_cache’ failed

I don’t know how to solve it and also the information I found on the internet are very unaccurate.
Do you have any suggestion about it?

Let me know pls.

I’d recommend to start with a clean environment and try to build a reference image as described here.

Can you build a reference image as it provided by Toradex with no errors?

I tried yesterday morning (in particoular I tried to build tdx-reference-minimal-image), I got similar error:
The postinstall intercept hook ‘***’ failed

The package was different, this is why I put ***, but the result was the same: on do_rootfs bitbake stopped.

I’m trying to compile tdx-reference-minimal-image on another linux machine and everything seems ok.
It sound strange, since I’m using on both machine the same Linux distribution, the same meta and the same recipes.

Thanks for the update. Look likes your issue is solved.