Windows CE8 C# applications do not start

I am setting up a development environment for Windows Embedded Compact 2013 on a Colibri iMX6DL using Visual Studio 2013. Following the steps described in the documentation, I have successfully installed the OS on the Colibri module and the SDK on the development PC.

From within Visual Studio, I can create a simple C# hello world project using the correct template. It builds, fine, and I can deploy the project to the target. It shows up in /Temp/DeviceApplication1 (or whatever the project name is). However, when I manually start the application on the target, it fails to do anything. For a GUI application (Device Application) nothing is shown on the screen, and nothing shows up in the Task Manager. No error messages or other dialogs are shown.

When I make a C# Console Application and try to start it from the command line (again, on the target), it simply returns to the command prompt immediately, without any message whatsoever.

When I try to start either application for debugging from Visual Studio (after successful deployment) I get a message saying “The application could not be launched for debugging”.

Strangely though, all this is specific to C#. C++ projects work just fine. A C++ Win32 Console Application happily prints text in the console, and a Win32 Windows Application will pop up a window and work as expected. I can also debug the applications as expected.

What could be the problem here? If you require more information to help me, please let me know.

Thanks in advance,


Did you install the .NET Framework permanently? If you deploy an application with Visual Studio, .NETCF is deployed automatically but not permanently, it is gone after a reboot. Try once to install the .NETCF installer we provide on our website.

If this was not the issue, please enable once the debug output, may be we get some more information there. You find some instructions how to enable the debug output here.

Thank you, this solved my issue!

Just to clarify though: You mention .NETCF is deployed to the target when deploying an application from VS. However, this apparently did not work in my case, as I was never able to either run or debug an application I deployed from VS, with or without a reboot in between.

Thanks @samuel.tx …Hi im facing this same issue and solved by .Net Framework


Thank you for your validation and reply.