Windows CE MTU values

We are having some problems with MTU size using VPN and FTP. These manifest in interrupted FTP transfers and VPN problems setting up connections. We have seen MTU values of 1400 in the logs of our VPN server when connections failed and then the logs of the vpn servers show 1392 on successful connections. We have noticed this a lot and have tested these values using ping -f -n 1 -l 1400 for example. and then with ping -f -n 1 -l 1392

With these results and after reading the WinCE 7.0 documentation we tried to set the PMTU to off and tried to set the MTU values of our network adapters to lower values… like 1000 to see if we can solve the issue and not see problems with failed vpn connections and ftp connection dropouts…

but we don’t understand how the registry keys actually interact with the OS and drivers for the network adapters. We set the registry keys, reboot the system, but using “netstate /e” or a custom utilllity I wrote to read the MTU values for the adapters… we don’t see the MTU values that we specified in the registry keys. It is almost as if the drivers simply ignore those settings (at least according to the netstat output).

Please help, what do we need to do here?

Colibri T30
BSP 2.8
Ce 7