Wifi interfaces unstable


my wireless interfaces change randomly on boot. On some boots I have “mlan0” and “wlp1s0” and on other boots I have “wlp1s0” and “uap0”.

What do I need to modify that I have every time a “mlan0” interface? And preferably no uap0 ever.


Colibri iMX8QXP 2GB WB IT
BSP 5.3

Hi @tuomas86,

On SOMs with the Azurewave wifi, uap0 is the access point mode interface and mlan0 is the station mode interface.
Both should always be present. I don’t know what is causing the wlp1s0 to be present as well.

Could you share more details about your setup?

  • Which Wifi chip are you using? Which software?

I believe there are settings you can enable for predictable interface naming which might affect what you’re seeing and I don’t believe it’s enabled by default.

Best regards,


They seem to be renamed during boot, but not consistently. Sometimes

mwifiex_pcie 0000:01:00.0 wlp1s0: renamed from uap0

and other times

mwifiex_pcie 0000:01:00.0 wlp1s0: renamed from mlan0

I wouldn’t mind the renaming, if it happened always to the same interface.
I believe imx8qxp has Azureweave AW-CM276NF. I use NetworkManager but same happens with connman.


Hi @tuomas86,

I’ve been testing the wifi here on my side and mlan0 is the only interface that is showing up. Have you done something with your image (maybe a wifi custom setting) that might be causing this?

Despite of that, I could disable the uap0 changing the file /etc/modprobe.d/mwifiex.conf from 0x3 to 0x1:

# cat /etc/modprobe.d/mwifiex.conf 
options mwifiex driver_mode=0x1

This will change the internal parameter for the driver:

 39 module_param(driver_mode, ushort, 0);                                                                                                                     
 40 MODULE_PARM_DESC(driver_mode,                                                                                                                             
 41                  "station=0x1(default), ap-sta=0x3, station-p2p=0x5, ap-sta-p2p=0x7")

For the network manager though, I found this ticket that might help you: Torizoncore 5.5 Disable the uap0 interface permanently

Please, let me know if this helped you.

Best regards,

Thank you, this mwifiex.conf setting fixed my issue. Now uap0 never appears and mlan0 is always renamed to wlp1s0. I tried the networkmanager configuration file, but it didn’t work for me.

1 Like