WiFi interface not appearing on Verdin iMX8M mini after power ON

Sometimes the SoM WiFi adapter/interface does not appear after powering on. This doesn’t always happen, but when it does I can’t reboot the AW-CM276NF module. If I turn off the SOM and turn it back on, the error disappears.

When the WiFi interface (mlan0) disappears, I have tried removing the driver and reloading it but this does not solve the problem. Apparently the driver when booting does not force the reset of the AW-CM276NF module and checks if the module has its firmware loaded. Since the module already has the driver firmware loaded, it does not load it again and the WiFi interface does not appear. Below I show the console output when performing this test.

NOTE: During these tests the system never goes to sleep.

According to the data sheets of the AW-CM276NF module there are 3 sources to reset the device. Do you have implemented the reset through sw/fw or gpio?

I have a Dahlia v1.1B board with the Verdin iMX8M Mini Quad 2GB WB IT V1.1B based. The image used is your Linux Multimedia Reference 5.4.0+build.11

I hope someone can help me.
Best regards,

Hi @jbruno !

Thanks for all the information and test shared!

Could you kindly test on the latest version of Reference Multimedia version?

It would be great if you could check on 5.7.1 and on the latest 6 available.

Meanwhile, we will try to reproduce the issue as well.

Best regards,

Hi @jbruno,

Thanks for reaching out to us!

I have tried to reproduce your issue on reference multimedia image versions 5.4 and 5.7, using the same hardware setup as yours. I can confirm that the wifi interface ie, mlan0 is not made available by default on an initial power on. This means you will not see it listed if you run the command ifconfig.

You can enable the wifi interface by running the command connmanctl enable wifi. After this if you run ifconfig you will see mlan0 listed as an available interface. Then you can scan the wifi, register the agent, list down the services and connect to your desired service using other connmanctl as they are explained in this article.

Once you have enabled the wifi and connected to a service, you will see it connected even after multiple reboots. I’m guessing that you are missing the step to enable wifi which makes you run into this issue. Could you please give this a try and let me know if that solves the issue?

Regarding this: I’m checking it internally and will let you know as soon as I have an answer.

Hi @rudhi.tx
The Wi-Fi interface is enabled and working normally. The problem is that sometimes (after a power on or reboot) the wifi interface disappears and there is no way to get it working again except by shutting down or rebooting the system. Below you will see that even running the command connmanctl enable wifi the wifi interface does not appear.

We have made a python script to detect this issue. Basically what you do is check if the mlan0 interface exists after the system boots. If the interface exists, we restart the system and if not, we stop the script and report the failure. With BSP 5.4.0 this error is repeated several times in an hour. We will repeat our tests with more recent versions but we would like to know if you have reported this bug.

Best regards,

Dear Julian,

Thanks for the reply. I haven’t been able to reproduce your issue here on my end.
May I ask you some more questions that would help us understand better:

  1. Are you seeing this behavior after some reboots? If yes, is it a hard or soft reboot?
  2. Have you noticed any patterns associated with what you are doing on the module that could lead to this issue?
  3. Is it possible for you to share some details or steps on how to reproduce this issue?
  4. Could you please send the output of dmesg - output of boot when the wifi interface failed to show up?

We have made a python script to detect this issue.
Could you please send this script which I can use in case I manage to reproduce the issue?

It would be great if you can send these in text formats. You can upload these files at https://share.toradex.com/ and post the share link here.

Dear Julian,

EDIT: It is not so easy to reproduce this issue.

May I ask you the frequency with which you see this problem? How often does this happen?

After discussing it internally, I can tell you that we have seen such issues very rarely in the past on 5.x versions of the BSP. However, these issues were taken into consideration in BSP 6.1 and it could improve the situation much better. Could you please give it a try on BSP 6.1 instead?

Hi @rudhi.tx,

Our test is quite simple. We have activated a service (eyesynth-wifi-test2.service) with sytemd which, after system boot, executes a script (wifi_reboot_test.sh) that checks that the mlan0 interface is available.If the mlan0 interface is available, it reboots the system, otherwise it prints an error message to the console.
We have also detected this issue after power ON and We have reported this issue in several Verdin modules.
I share the files with this link. Download - Toradex File Sharing Platform
We have done some tests with your BSP 6.1 multimedia reference image and the issues we have reported all seem to be resolved. We are working on migrating our custom image to BSP 6.1 but we are having some issues.
Best regards,

Hello @jbruno,

We have done some tests with your BSP 6.1 multimedia reference image and the issues we have reported all seem to be resolved.

Good to hear that!

We are working on migrating our custom image to BSP 6.1 but we are having some issues.

Please let us know if you require any support there.