Wifi Access point connectivity verdin iMX8M plus

Hello there,

We are using the Torizon SOM and Carrier Boards as mentioned below,

iMX8M Plus 32GB V1.1A
Customized Carrier Board
Torizon Core OS

HOST PC - Ubuntu

  1. We access the Torizon SOM through the wired SSH connection using the LAN (RJ45) cable
    The Static IP was set using the procedure given in the URL (Networking with Torizon OS | Toradex Developer Center).

  2. Wifi Access Point mode was enabled using the procedures mentioned in the url (Networking with Torizon OS | Toradex Developer Center), once the network start is executed, the wired SSH connection becomes inaccessible

Is there anyway that ssh connection can be accessed in both the wifi AP mode and the wired SSH connection?

Hi, I’m the Toradex AI Assistant. I’m in early beta, and I would appreciate your feedback.
The Toradex Support team will follow up with you shortly!

Did you like my answer?

:+1: :-1:


Hello there,

When configuring the Wi-Fi Access Point (AP) mode on a Toradex module running TorizonCore, it’s important to ensure that the network configurations do not conflict and that both interfaces (Wi-Fi and Ethernet) can coexist without issues. Here are some steps and considerations to help maintain SSH access over both Wi-Fi and Ethernet:

  1. Separate IP Address Ranges: Ensure that the IP address range used for the Wi-Fi AP is different from the one used for the Ethernet connection. This helps in avoiding IP address conflicts. For example, if your Ethernet is configured in the 192.168.1.x range, configure your Wi-Fi AP to use a different range, such as 192.168.2.x.

  2. Static IP Configuration: For the Ethernet connection, you’ve already set a static IP. Ensure that this configuration does not interfere with the DHCP server settings of the Wi-Fi AP. The Wi-Fi AP should be configured to assign IP addresses in its own range to connected devices.

  3. Network Bridge: Consider setting up a network bridge if you need devices connected to the Wi-Fi AP to be accessible from the Ethernet network or vice versa. This is a more advanced setup and requires careful configuration of network interfaces.

  4. Firewall and Routing Rules: Check any firewall or routing rules that may be affecting traffic between the two interfaces. You might need to add rules to allow SSH traffic (port 22) to pass through from one interface to the other.

  5. Testing and Validation: After configuring the Wi-Fi AP and ensuring the Ethernet connection is still active, test the connectivity by trying to SSH into the Toradex module from a device connected to the Wi-Fi network and another device connected via Ethernet. This will help identify any connectivity issues.

  6. Network Service Configuration: Review the network service configurations to ensure that both the Wi-Fi and Ethernet services are set to start automatically and do not conflict with each other. In some cases, network managers might disable one interface when another is activated, depending on their configuration.

If after following these steps, you still encounter issues where activating the Wi-Fi AP mode disrupts the Ethernet SSH connection, it might be necessary to review the specific network configurations and logs to identify the root cause. Ensure that both interfaces are correctly configured and that there are no underlying network conflicts causing the SSH connection to drop.

Best regards,
Toradex AI Assistant

Please, also check if these links can help you solve your problem:

How to Setup Wi-Fi Access Point Mode (Linux) | Toradex Developer Center.

Greetings @nisha,

As the ToradexAI bot suggested you may have configured your access point with conflicting IP address. For example if your wired Ethernet has an ip address of “192.168.1.15”. Then you should not configure the access point with any “192.168.1.X” address, or there will be a conflict preventing SSH. I tested this myself to make sure. You should instead give your access point a different IP range as suggested. As an example here’s how I configured my access-point while still having SSH be accessible on the wired Ethernet:

# /etc/hostapd.conf

interface=uap0
ssid=test
hw_mode=g
channel=1
own_ip_addr=192.168.2.100
# /etc/systemd/network/80-wifi-ap.network

[Match]
Name=uap0
Type=wlan
WLANInterfaceType=ap

[Network]
Address=192.168.2.100/24
DHCPServer=yes

[DHCPServer]
PoolOffset=10
PoolSize=30
EmitDNS=yes
DNS=1.1.1.1

This avoids any conflict as my wired Ethernet has an address in the “192.168.1.X” range.

Best Regards,
Jeremias