Where is the OS version set (eg. 4.1 or 4.4) for WinCE 5.0?

How do I set the build version of a WinCE 5.0 OS for my PXA320 SBC (the 4.1, 4.4, etc, not the WinCE 5.0). I’m using an old Platform Builder 5.0 setup left by a co-worker no longer with the company. I downloaded the pxa_wince5_workspace_4.1 and pxa_wince5_workspace_4.4 files and copied them to the PBWorkspaces folder on the build machine. I opened each one up using the .pbxml file and ran Sysgen under Build OS. But when I load the nk.bin file that’s created (via Colibri Update tools) to an SBC and then check the version via the Update Tool, it says 3.9 (which was the version last used and built by the co-worker who used to run the builds).

I also tried Build and Sysgen. And I also tried importing the pxa_wince5_bsp_4.1 and pxa_wince5_bsp_4.4 downloads into the workspaces but those tries still result in Version 3.9 in the Update Tool display.

When I download the images from Toradex (pxa_wince_image_4.1, etc), they do show the correct Version in the Update Tool.

This is my first time using PB, so I might be missing something obvious. I’ve searched on the in the community but nothing I’ve found so far has worked. Thanks for any insights!

The BSP version is linked in the BSP binaries. You cannot change them. You most probably didn’t do a “Clean Before Building”. Select this option first from the build menu and then do a Sysgen again (only sysgen, not build and sysgen!). This should generate a new nk.bin file using the latest BSP. If there is no nk.bin, also execute Build Run-time Image.
Can you check the file date of the nk.bin file you created? It should have the build date when you built it.

Thanks very much for the suggestions. I originally did not have “Clean Before Building” set when I started the project, but in the recent days I set it, before posting. I tried a few more attempts today, started each one with a fresh copy of the Toradex_000_Core folder from the pxa_wince5_workspace_4.1.zip download. In all attempts still, the version after I install on the SBC is 3.9. Another thing that is likely related but I forgot to note before: the WinCE image download from Toradex boots up with the screen size set to 640x480, but the builds all come up 240x320 (which is a size we build into the OS here).

At first today (and in the past before posting at all), I renamed Toradex_000_Core for each new build, preserving the Toradex_000_Core folder that existed before I inherited this project. But in one attempt today, I did not find nk.bin and noticed in the Build tab output it has been placed in Toradex_000_Core, not the workspace I opened (?).
So then I renamed the older Toradex_000_Core folder and copied a fresh download copy to the build system and did not rename it.

Originally, I had the three options in my PB set: “Clean Before Building”, “Copy Files to Release Directory After Build”, and “Make Run-Time Image After Build”. I played with turning off the “Make Run-Time Image…” setting (that’s when I discovered nk.bin was not going to the current workspace). I have it checked again now.

I did not install the BSP today, only tried the workspaces from the Toradex site. Also, I have only been copying the folder into the PBWorkspaces folder on the build system…nothing is copied to the parallel folders (PUBLIC, PRIVATE, PLATFORM, etc). Is there some file somewhere buried in all that that is “stuck” somehow?

I forgot to mention in the first post that the build system for all this is an XP VM running under Windows Virtual PC (on a Windows 7 system). The About PB says copyright 2004. (This is what I inherited and need to preserve, at least to figure out the customization that the original employee added in the past.)

Any more ideas? Thanks!

Woo! That helped a lot. Didn’t work when I put the BSP in C:\WINCE500\colibri, actually. Big clue was that there wasn’t an existing folder there but I tried it anyway. After that, I ran a search for colibri.cec files and found the BSP was in C:\WINCE500\PLATFORM\colibri. I renamed that, copied in the 4.1 BSP and t then I built a 4.1 OS using the downloaded 4.1 workspace from Toradex. That worked! I don’t know why the path differed from your instructions: if the previous guy set something up special on this system or it’s just so old that was the path or something else, but I’m able to move on now. So, thanks!!

Another question, if I may: is there a 3.9 workspace download from Toradex? I found the 3.9 BSP and image but the workspaces at http://docs.toradex.com/102536-pxa-wince5-workspace don’t go lower than 4.1. I’d like to use a plain 3.9 workspace to compare to. I am not sure where it is on the build VM…the previous user renamed it and there are over 50 workspaces on the VM.
Thanks again, this was a big help.

I uploaded the
workspace for our PXA WinCE 5 V3.9BSP on our sharing server.

@meg: Where did you put the latest BSP files to? They need to be in WINCE500\colibri. To make sure you don’t build the old BSP, you need to rename the old one, do not mix the old and new BSP in one folder. As the version of the image is defined in the BSP folder, I assume this is the issue on your side.

You have to manually merge BSP and Workspace with your modifications. Normally customers only add some files and modify the registry. In order to understand what your college has modified on the default BSP, please try to compare mainly *.reg and *.bib files. There you will see all the registry modifications and the files which have been added to image. Migrate the changes to the new BSP and you should be fine.