What do i have to adjust to connect a 7" HDMI display with the Apalis TK1

I would like to connect a 7" HDMI display to my Apalis TK1 but it does’t work. Specifically, the display shows the message not connected. On the minicom terminal i can see the message tegra_dc_hdmi_irg:start and tegra_dc_hdmi_irg:end (i think this is the EDID)

Some information:

  • i use the current image version Apalis-TK1_LXDE-Image 2.7.2 20170410
  • i use this touch display Link

Which i have already try:

  • with the command xrandr : xrandr --output HDMI-0 --mode 1024x600
  • List item
  • i wirte into the file xorg.conf the “PreferredMode” “1024x600”
  • from the U-boot command line: setenv vidargs ‘video…’ and saveenv

Which carrier board are you using?

We found an incompatibility issue when using Apalis TK1 in combination with an Ixora carrier board (V1.0 or V1.1). The voltage levels used on the DDC signals for HDMI are not compatible in worst case. The input low level maximum voltage is lower than the output low level maximum voltage. This could be the problem with your setup. Please confirm if you are using Ixora.
We will document this issue in detail in an errata document for Ixora V1.0/1.1 and Apalis TK1 V1.0/V1.1. We currently don’t have a nice workaround for this but are also working on finding a solution.

Thank you for your answer. Yes i use the Ixora carrier board V1.0. I think this could be the problem. Can you tell me whether this problem also exist with the Apalis T30?

Apalis T30 does not have this issue.

On Apalis TK1 it also usually is only an issue on hot-plugging and should work fine if the HDMI screen is already plugged-in during boot. However exact behaviour is dependent on the cable and screen used. Have you tried different ones?

Ok, yes i tried some different HDMI cables. I also tried a different monitors.

This is the answer, when i write the command xrandr:

root@apalis-tk1:~# xrandr
Screen 0: minimum 8 x 8, current 1024 x 600, maximum 16384 x 16384
LVDS-0 connected 1024x600+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x600      62.89*+
HDMI-0 disconnected primary (normal left inverted right x axis y axis)

I don’t understand why the HDMI-0 port is disconnected.

Can you see prints like these in dmesg:

Failed to read EDID after 5 times. Giving up.
hdmi_state_machine_set_state_l: switching from state 2 (Check EDID) to state 3 (Disabled)

? If you do then it’s an issue with TK1 and ixora and HDMI will be reported as disconnected, currently there is no known workaround for it. If you don’t, is there any output in serial console when you unplug and plug the hdmi cable?

no i can’t see this massage. When i unplug and plug the hdmi cable i see this on the serial console:

[   47.237924] tegra_dc_hdmi_irq: start
[   47.242500] tegra_dc_hdmi_irq: end
[   47.246430] tegra_dc_hdmi_irq: start
[   47.250444] tegra_dc_hdmi_irq: end
[   47.259928] hdmi_state_machine_worker (tid edaf2080): state 3 (Disabled), hpd 0, pending_hpd_evt 1
[   47.270005] hdmi_state_machine_set_state_l: switching from state 3 (Disabled) to state 0 (Reset)
[   47.319895] hdmi_state_machine_worker (tid edaf2080): state 0 (Reset), hpd 0, pending_hpd_evt 0
[   47.332274] hdmi_disable_l: audio_switch 0
[   47.336593] hdmi_disable_l: hpd_switch 0
[   47.340655] hdmi_state_machine_set_state_l: switching from state 0 (Reset) to state 1 (Check Plug)
[   47.359930] hdmi_state_machine_worker (tid edaf2080): state 1 (Check Plug), hpd 0, pending_hpd_evt 0
[   47.369361] hdmi_disable_l: audio_switch 0
[   47.373618] hdmi_disable_l: hpd_switch 0
[   47.377661] hdmi_state_machine_set_state_l: switching from state 1 (Check Plug) to state 3 (Disabled)

This log shows only the unplug event, there should be more after you’ve plugged the hdmi cable back in. Can you share boot with hdmi connected, after board has fully booted unplug HDMI, wait 10s, connect hdmi again then capture dmesg output and upload it.

You can find the log file here:

link text

Can you test it with different module and/or Ixora?