WEC7 image flashing into iMX6 Dual 1 GB IT

Hello ,

we have an image that works well with Apalis iMX6 Quad 2 GB IT.
I got a sample of Apalis iMX6 Dual 1GB IT. After flashing our image into this module and repowering the screen is black.
Image size (nk.nbx) is 34 MByte.
After putting module into IXORA board and connecting serial link I get message “Industrial tempeature grade DDR timings
Trying to boot from MMC1”

I can not get into boot menu.

Any ideas ?

Kind regards

Could you please load the Toradex Easy Installer using recovery mode and then flash WinCE7 version from Toradex Server?

Hello Alex,

I could enter recovery mode (hardware method) and successfully installed easyinstaller 5.7.1-build13 (see easyinstaller.png).

But on my HDMI monitor I get message „no HDMI signal“.

On serial debug port I get message shown in dbugport.png.

I assume I should see Easyinstaller on my HDMI display to be able to flash WinCE7 version from Toradex Server.

Kind regards



Could you pleas specify carrier Toradex Easy Installer version? Have you tried another HDMI cable and/or monitor?

my remark “successfully installed easyinstaller” was wrong. I did not install it but only loaded it into RAM. So after repowering there was no easyinstaller anymore.
Now I did not repower after loading easyinstaller and installed WEC7 version from Toradex server. This worked. Then I installed our image using update.exe. This worked too.
Now module is running with our image.
I retried directly with our imgage (loading easyinstaller and then directly installing our image). This worked too.
So at the moment I do not know what went wrong when I tried first.

However I do not know whether the starting point is the same as the first time I tried this.

The only strange thing I see now is that ConfigBlockEditor does not run.

Anyway we will see when I get another such module. But maybe you can check ConfigBlockEditor.
Thank you !
Kind regards

Could you please specify WEC7 BSP version you have installed? And what was exactly happened when you started the ConfigBlockEditor? Could you please enable debug serial port and collect logs?

Also with Toradex Image 1.8 Configblockeditor does not work. Please find attached serial debug output

Please use the latest (1.13) version of the Configblock editor

Have you solved problem with HDMI? WHen you load Tradex Easy installer HDMI works by default. If you flash WinCE you must configure display driver to enable HDMI.
You can also configure desired output using SS settings at eBoot .

As said above everything is working now except ConfigBlock editor.

I am using latest version 1.13 and image 1.8 downloaded from Toradex server.
I get an exception (see capture.txt).
it works without problems with imx6 Quad

According to provided capture.txt your module may be affected by Forced Read Only Mode issue.
Please check this article and run suggested MMC tool


MMc tool did not change situation. ConFigBlockEditor still not running.

Kind regards

Mit freundlichen Grüßen / best regards

i.A. Franz Hofer
Entwicklung - R. & D.







You can return this module for fixing. Please use this form Return Material Authorization (RMA)