WEC2013 doesn't boot with large OS image

Our compressed OS image has increased in size and doesn’t boot anymore
The old image was 34 MB, the new image is 74 MB (I’ve just added some locales/fonts for chinese/japanese).

The reserved space for the OS image in the flash layout should be large enough, so what could be the problem?

Here is the debut output, the splashscreen is shown, but the OS doesn’t start.

664-putty.jpg

Do you have debug output enabled in the image?
You can check the dbg.serial parameter on the boot console:

  • stop automatic boot process by pressing space on the serial terminal at power-up
  • press ‘x’
  • type: set dbg.serial
  • if it’s not 1, type:

    set dbg serial 1

    and then

    save dbg
  • reboot and you should see other messages after “Launching image…”

debug output was already enabled, i did check that before.

Although dbg.serial was already set to 1, I did

set dgb.serial 1
save dbg

and the image is booting now.

I tried the larger image with another module and the OS doesn’t boot too.
Setting dbg.serial didn’t fix the boot problem.
I tried the bootloader 1.3b3 you sent to my colleague, this is the output:

That new bootloader is not able to load images of 1.2 release, it was released to test a specific issue.
The maximum image size allocated in config.bib is 94MB, if you want to build a bigger image you’ll need to change those parameters and generate a suitable nb0 file.
If you want you can install additional language-specific fonts using cab files:
https://developer.toradex.com/knowledge-base/how-to-install-additional-fonts
This will decrease image size, improve boot time and leave much more free RAM for your software.

I have installed the additional fonts for japanese and chinese, but the japanese/chinese text is not displayed correctly (see image below for the xaml definition and how the text is shown). The registry settings for the fonts seem to be ok, they correspond to the values which are listed in your link.

When the fonts are included in the OS image, the text is shown.

676-chinese.jpg

For Silverlight you will have to do some additional work to make fonts work →

https://msdn.microsoft.com/en-us/library/jj592928.aspx

Also next time please open a new question for not related issues!

I have changed config.bib for the larger image (increased NK_SIZE and changed RAM_START accordingly), but the image doesn’t boot. Did i forget something?

[upload|Jtzr7lfoZFwd5rF/g8EGgW3kbno=]

This is the output on the serial port (dbg.serial is set to 1):

[upload|jS2iWDDNpyS3ugNmal/8lE5RLi8=]

You should also reduce RAM size, otherwise some memory regions will overlap

I have reduced the variable RAM_SIZE, but the image won’t boot either.

Original values in config.bib:

	#define NK_START    80200000
	#define NK_SIZE     05E00000
	#define RAM_START   86000000	
	#define RAM_SIZE    04000000		; defined as minimum amount of 64MB to allocate video ram

Changed values:

	#define NK_START    80200000
	#define NK_SIZE     07E00000
	#define RAM_START   88000000	
	#define RAM_SIZE    02000000		; defined as minimum amount of 64MB to allocate video ram

can you please upload your os design and configuration files on share.toradex.com so we can try to reproduce the issue?

These are the differences to our standard images :

I’ll send you the download link to the files via e-mail.

@haide,

Did you use release NK.bin? if you build release image then OS image file will be in “\OsDesigns\IMX6_Core2013\RelDir\TORADEXIMX6BIN_ARMV7_Release”.

Also, share release directory files through share.toradex.com , it will help us to solve the issue quickly.

We’re building a release OS.

But does it really matter if it is a release or debug build?
The image is larger because of the added chinese/japanese/korean fonts.

I sent the download link to valter directly because there are some of our application files in the download.
Is there a way to mark an upload to share.toradex.com as “downloadable by toradex employees only”?

Sorry, missed sync on our side. You don’t need to send the files again.

Was there a resolution to this question?

The compressed image is working with bootloader 1.3b4 and the new image compression tool.

Can you convert your comment to an answer so that i can accept it as solution?

Yes.
If you use the image in .bin format it work in version 1.3b4 of the BSP and Image.
If you use compressed image you’ll neet to contact us for an updated version of the image compression tool (will be published soon, still under testing, we can provide it directly if you need ti immediately and already bought it in the past).