Webdav activation in wince6 httpd web server

Hello,

I’m trying to activate webdav in wince6 (Toradex VF61). I’m using that documentation : WebDAV (Windows Embedded CE 6.0) | Microsoft Docs but unfortunately, it doesn’t work. Here are the registry :

[HKEY_LOCAL_MACHINE\COMM\HTTPD\VROOTS/directory]
@="\www\test"
a=“0”
DirBrowse=“1”

Did I miss something ? It’s obviously uncomplete.
P.S. : accessing http:///directory is working : I can see the content of \www\test.
But WebDAV test failed : “Command not implemented (OPTIONS /directory 501)”

Many thanks for any help…

I would like to specify that some characters disappear in my post :

the directory brosing is working when I try to access h t t p : / / device / directory

Hi @ANSEL ,

Unfortunately the WebDAV component is not included in our standard Image, so if you need that functionality you need to build your own Image with Platform Builder and our Workspace + BSP packages.

Thanks a lot for your answer.
It helps !

J.M. ANSEL

Hello,

Thank you very much for your answer. I tried the way you indicate but unfortunately, I don’t know how to install PlatForm Builder for winCE 6.0 on visual studio (2008 in my case). … Is there a PlateForm Builder for visual studio 2008 and where ?

Many thanks

----- Mail original -----

Hi! You can download it from the official Microsoft website

Thank you for your answer ! Unfortunately, this msi is for Visual Studio 2005 Only… It doesn’t complete with Visual Studio 2008… Argh :frowning:
If you have an idea…

J.M. ANSEL

----- Mail original -----

Hi @ANSEL ,
If the issue is only the Visual Studio, you can install Windows CE 6.0 also without Visual Studio. You can then either use it in command line build mode, or do it like we do here at Toradex and use VS2008 + PlatformBuilder for CE7 to open CE6 workspaces. This works for us so we don’t need to use VS2005 anymore.

Hello,

OK I have succeeded in installing PlatForm Builder in VS 2008 ! But Now I need a valid WINCEROOT image for ARMV4l architecture… I don’t know where I can find it… Is it possible to download one please ?

----- Mail transféré -----

Hello! You check this page? As @germano.tx said, you need Workspace and BSP for your device

Hello,

I managed to regenerate the toradex image with pxa_wince6_workspace_4.5.zip under VISUAL 2008 !

But now, when I install the image, FlashDisk driver doesn’t detect the flashdisk and it is impossible to format and partition it.

Don’t you have the last workspace used to generate your image pxa_wince_image_4.6 including all options for a PXA300 Card please ?

I have tried to regenerate with some specific options that are not used :

SYSGEN_FLASHMDD=1
SYSGEN_MSFLASH_STRATAD=1

But it’s not enough to let the flashdisk driver work…

If you have some idea… Thanks a lot !

----- Mail original -----

OK, in fact, we have the 19Mbytes limit that disable the flashdisk access… Shrinking the image under 19Mb let appear the flashdisk…

Hi @ANSEL ,

If you need to have a bigger Image you can reduce the area reserved for flashdisk. This is a bit more complicated as you also need to shift the registry location. Take a look at this article: