WDT Reset cause status is not updating in reset cause

I am able to trigger wdt event in my imx8mp verdin board and restarted the board but uboot is not updating reset_cause register correctly as WDT event but POR (power on reset) which is incorrect.
What could be the issue ? is it bug in SOC which have now ? or is it needs any patches ?
I have tried to read SRSR register in SPL code, (just after BOOTROM) but still I see 0x1 value i,e POR
Also tried to use init=/bin/bash in bootargs to boot board without any systemctl stuff but still not observing correct reset_cause value.

Here is my bootlog.
wdt_debug_log.txt (29.8 KB)

1 Like

Any response from Toradex Engineer ?
We are completely blocked.
I have enabled to print ext-reset-output in WDT driver and can see 0 as expected, but wondering how can I see still reset_cause as 0x1 even wdt event is resetting SOC, looks like something in Verdin i.MX8MP SOM module related to PMIC

Hi @titusece ,
We are looking into it.

Hi @titusece ,

Yes, you are correct.
WDOG_B (GPIO1_IO02) is connected to the PMIC IC which triggers the reset due to which it is showing POR as the reset reason.
Unfortunately, there is no straight way to get the reset reason as PMIC resets CPU (POR), so, irrespective of the reset source, final reset will be done by PMIC which in turn will show POR as reset reason

Similar issue mentioned here.

Understood, thanks for your support.