Warning - bad CRC, using default environment

I’ve been trying to load ath10k drivers on my Apalis iMX6/Ixora. I’m resetting my module to the latest U-boot and Kernel with no modifications. Everything seems OK except I’m getting "*** Warning - bad CRC, using default environment ". See attached:

link text

You can resolve this issue by resetting the U-boot environment. From the U-boot console, enter:

env default -a

Upon boot up, check to see if you see the same message. Note that this will reset the U-boot environment to its default state, so if you require some variables to be set otherwise, you will need to manually set them.

Great, that worked. Thanks Brandon

Any other possible solution apart from this , like without entering any thing in uboot. may be possible to define any other way ??


Yes, doing nothing.

U-Boot is taking the built in default environment when nothing has been saved into non-volatile storage so far.

So if you want to use the default environment then nothing needs to be done and the message tells you that you are using the defaults.

As soon as you change or add any enviroment variable and save the environment then

  • the new settings take effect now and on the following boots
  • the message is not printed on the following boots.


Ok thanks i got it

I resolved it.thanks for the help