Want to access device gui in host pc

Hello
I am new bie in yocto/OE
I am using imx6ull aster carrier board. i want access of board gui application in my host pc.
i already added x11vnc and remmina in local.conf file and rebuild image but when i try to connect it says connection refused by the computer and

 x11vnc             
###############################################################
#@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@#
#@                                                           @#
#@  **  WARNING  **  WARNING  **  WARNING  **  WARNING  **   @#
#@                                                           @#
#@        YOU ARE RUNNING X11VNC WITHOUT A PASSWORD!!        @#
#@                                                           @#
#@  This means anyone with network access to this computer   @#
#@  may be able to view and control your desktop.            @#
#@                                                           @#
#@ >>> If you did not mean to do this Press CTRL-C now!! <<< @#
#@                                                           @#
#@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@#
#@                                                           @#
#@  You can create an x11vnc password file by running:       @#
#@                                                           @#
#@       x11vnc -storepasswd password /path/to/passfile      @#
#@  or   x11vnc -storepasswd /path/to/passfile               @#
#@  or   x11vnc -storepasswd                                 @#
#@                                                           @#
#@  (the last one will use ~/.vnc/passwd)                    @#
#@                                                           @#
#@  and then starting x11vnc via:                            @#
#@                                                           @#
#@      x11vnc -rfbauth /path/to/passfile                    @#
#@                                                           @#
#@  an existing ~/.vnc/passwd file from another VNC          @#
#@  application will work fine too.                          @#
#@                                                           @#
#@  You can also use the -passwdfile or -passwd options.     @#
#@  (note -passwd is unsafe if local users are not trusted)  @#
#@                                                           @#
#@  Make sure any -rfbauth and -passwdfile password files    @#
#@  cannot be read by untrusted users.                       @#
#@                                                           @#
#@  Use x11vnc -usepw to automatically use your              @#
#@  ~/.vnc/passwd or ~/.vnc/passwdfile password files.       @#
#@  (and prompt you to create ~/.vnc/passwd if neither       @#
#@  file exists.)  Under -usepw, x11vnc will exit if it      @#
#@  cannot find a password to use.                           @#
#@                                                           @#
#@                                                           @#
#@  Even with a password, the subsequent VNC traffic is      @#
#@  sent in the clear.  Consider tunnelling via ssh(1):      @#
#@                                                           @#
#@    http://www.karlrunge.com/x11vnc/#tunnelling            @#
#@                                                           @#
#@  Or using the x11vnc SSL options: -ssl and -stunnel       @#
#@                                                           @#
#@  Please Read the documentation for more info about        @#
#@  passwords, security, and encryption.                     @#
#@                                                           @#
#@    http://www.karlrunge.com/x11vnc/faq.html#faq-passwd    @#
#@                                                           @#
#@  To disable this warning use the -nopw option, or put     @#
#@  'nopw' on a line in your ~/.x11vncrc file.               @#
#@                                                           @#
#@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@#
###############################################################
09/07/2024 11:20:34 x11vnc version: 0.9.16 lastmod: 2019-01-05  pid: 746
09/07/2024 11:20:34 XOpenDisplay(":0.0") failed.
09/07/2024 11:20:34 Trying again with XAUTHLOCALHOSTNAME=localhost ...
09/07/2024 11:20:34 Wayland display server detected.
09/07/2024 11:20:34 Wayland sessions are as of now only supported via -rawfb and the bundled desksho.

i am doing wrong. let me know what to do

Hi, I’m the Toradex AI Assistant. I’m in early beta, and I would appreciate your feedback.
The Toradex Support team will follow up with you shortly!

Did you like my answer?

:+1: :-1:


Hello,

To access the GUI of your iMX6ULL Aster carrier board from your host PC, it seems you’re encountering a couple of issues related to VNC setup and Wayland display server detection. Let’s address these step by step.

  1. VNC Connection Refused: This could be due to several reasons including the VNC server not running on the target device, network issues, or firewall settings blocking the connection. Ensure that the VNC server is started on your board and that there are no network/firewall issues preventing the connection.

  2. Running x11vnc Without a Password: As the warning suggests, running x11vnc without a password poses a security risk. It’s strongly recommended to set a password for VNC sessions. You can set a password by running:

    x11vnc -storepasswd your_password_here /path/to/passfile
    

    And then start x11vnc with:

    x11vnc -rfbauth /path/to/passfile
    
  3. Wayland Display Server Detected: x11vnc is designed to work with X11, and it seems your system is running Wayland. Since x11vnc cannot directly interface with Wayland, you have a few options:

    • If your application allows, switch to an X11 session instead of Wayland. This might not be straightforward on all systems and depends on the specifics of your setup.
    • Use a VNC solution designed for Wayland, such as WayVNC. However, integrating WayVNC might require additional steps and is not as straightforward as using x11vnc.
    • Consider using alternative remote desktop protocols that support Wayland, such as RDP with solutions like FreeRDP or using other remote access tools that are compatible with Wayland.

Given the complexity of your setup and the specific challenges related to Wayland, you might need to evaluate the best approach based on your project requirements and the flexibility of your environment. If switching to X11 is an option for your application, it could simplify the use of x11vnc. Otherwise, exploring Wayland-compatible solutions or alternative protocols might be necessary.

Best regards,
Toradex AI Assistant

Please, also check if these links can help you solve your problem:

Remote Access | Toradex Developer Center.

i tried this but couldn’t connect

 x11vnc -rfbauth /home/root/.vnc/passwd
09/07/2024 11:56:36 passing arg to libvncserver: -rfbauth
09/07/2024 11:56:36 passing arg to libvncserver: /home/root/.vnc/passwd
09/07/2024 11:56:36 x11vnc version: 0.9.16 lastmod: 2019-01-05  pid: 776
09/07/2024 11:56:36 XOpenDisplay(":0.0") failed.
09/07/2024 11:56:36 Trying again with XAUTHLOCALHOSTNAME=localhost ...
09/07/2024 11:56:36 Wayland display server detected.
09/07/2024 11:56:36 Wayland sessions are as of now only supported via -rawfb and the bundled desksho.

i installed real vnc in my host pc