VS2008 Remote Tools for WinCE6

Hey Toradex,

I’m having an issue with the Remote Tools for WinCE in VS2008.
I’m trying to use the resource leak detector built in the Platform Builder but sadly i’ve stumbled upon issues.
I have no issues connecting to the WinCE device, but when i’m trying to use the resource leak detector the window is all blank, i can’t add any modules nor can i attach it to running processes etc.

I’ve attached a couple of pictures which explains everything pretty well.

pic1 I’m selecting the target WinCE Device that is connected to the PC.

pic2 It’s connecting to the device and transporting files to the device.

pic3 Connection to the Windows CE device has been succesfully established.

pic4 The resource leak detector is all blank, i can’t add any test modules or attach it to running processes or nothing.

Does anyone have any clues on why it’s all blank?

Thanks in advance.
Best regards,

Dear @KingCold ,

Unfortunately i cannot verify your findings as i only use CE7 development environment for both CE6 and CE7 and i installing both will make one of them not work properly anymore.

But i remember that it was working many years ago when i used it last time.

How did you install the Memory Leak Detection tool? As part of the CE6 Platform builder package?
Did you install Windows Embedded CE 6.0 Service Pack1 and then R2 and R3 Updates?
I know there were some issues with Windows Vista that were fixed with SP1 or R2 or R3… mabe the same also applies to Windows 10 (which i guess you’re using)

Hi Germano,
Thank you for your response!

I actually installed the Memory Leak Detector through CE7 Platform builder.
I thought that it had support for CE6 but maybe i’m wrong on this one?

I see, i already have SP1 installed but i will definitely take a look at R2 and R3.

Do you think i should get CE6 platform builder instead before proceeding with other fixes?

Just wanted to add in some info.

Platform Builder for CE 6.0 does not seem to be supported by VS2008, only VS2005 which i sadly don’t have.
Does anyone have any clarification regarding Platform Builder for CE7 being compatible with CE6?

Best regards

Dear @KingCold ,

Now that i know you are using teh CE7 Resource Leak Detector i testing it by myself, i could reproduce your issue…

Last time I used this was long ago… so it took me a while to undestand how this works…

The Resource Leak Detector (and many other remote tools) now are integrated into the Remote Tools Shell also known as Remote Tools Framework 1.10

The Remote Tools Shell can run in desktop mode or in remote connection mode…
Seems that by default when you start the Leak tool it enters in desktop more, and that’s why you don’t see any configuration options.

Try launching the Remote Tools Shell instead and from there click on the Resource Leak Detector (in the “Collect Live Data” List)
You will then have to select a Physically Connected Device (in my case it’s called “Mobile end Embedded Device”)
Then after the connection is established it should work.

I only tested with CE7 running on the device, but it’s very possible it’s working also with CE6.

I would not recommend to install CE6 on your desktop machine as it will most probably break your CE7 installation. If you really want to try you should use a VM or a machine without CE7 installed already.

Hi @germano.tx

Thank you so much for responding, really means alot!

I’ve tried this already, was sitting for 3 hours straight last night trying to solve it without solution.
I open Remote Tools Shell standalone and go to collect live data, choose my unit and it connects with success.
Then Remote Tools Shell starts loading it up but after 1-2 seconds it just pops back to the homescreen of Remote Tools Shell so that doesn’t work either.
It’s not the same issue as before but it still doesn’t work… :frowning:

I’ve also tried loading it through the Remote Tools Shell Plug-in Explorer in “View” toolbar by dropping down the “Mobile and Embedded Device” tree and double clicking on Resource Leak Detector. It also starts connecting successfully to the CE6 device but then Remote Tools Shell goes back to homescreen…

1 question, when i installed the Windows CE7 Platform Builder i only installed the Platform builder and not the whole CE7 SDK. Is this maybe needed for Remote Tools Shell to work you think?

Hi @KingCold ,

Just to make sure we are doing exactly the same, here is a video of what i’m doing:


Can you also give me some more details on what SOC you’re using?
Did you tr with CE7 instead of CE6?