Visual Studio 2019 'failed to connect over ssh'


I am following the tutorial for making a C program in Visual Studio and deploying it on the tordex board.

I am able to SSH in (use MobaXterm)
I am able to open the Torizon Devices window in Visual Studio. It shows Images,Containers,Processes on the Toradex Apalis iMx8 on the Apalis Evaluation Board

I started a new project using the Tordex default project.

When ‘Deploy and debug Torizon application’ I get the following error message:
Failed to connect over SSH due to host key mismatch. Please go to Tools|Options|Cross Platform|Connection Manager and select ‘Verify’ to resolve this.

I do that and I still get the same error message. It always wants to use localhost. I set the board as default and verify and I still get the same error.

In the solution explorer (right click properties) Iunder Debugging the Remote Debug Machine is set to apalis-imx8 (note authentication=Password)

What should I try? Why am I getting this error message?

Thank you



I reinstalled VS from version 16.10.2 to 16.7.0
I installed Toradex Torizon C/C++ Support extension (not the early access version as it doesn’t work)

These two combinations now work and allow me to write code and run it on the board.

Glad you were able to get things working. Thank you for the feedback regarding the VS versions, we’ll investigate this internally for any possible version incompatibilities.

By the way what did you mean by “not the early access version as it doesn’t work”. How exactly does it not work?

Best Regards,

Since you mention localhost, it seems that the issue is related to connection with the SDK container (running on your local machine) that is used to build the application before deploying it to the target.
We will investigate this, it seems that connection management has been changed in the new VS2019 release.


I am having the same issue with version 16.10.2. I have not tried doing 16.7.0 yet.

Thank you,

Hi @Pedrinh089,

Since this post was created our team has confirmed that there is compatibility issue with our extension and version 16.10.2. of Visual Studio. We are still in the process of investigating and producing a fix for this.

In the meantime I suggest downgrading to an earlier version of VS if possible. At least until we have our fix ready for the latest versions.

Best Regards,

Hi @jeremias.tx,

Thank you for the suggestion, I switched to version 16.7.16 and it seems to be working.

Best Regards,


Glad to hear this works for you. Please use this version of VS at least until we have a fix for the later versions.

Best Regards,

Greetings everyone in this thread we now have a fix in the Early Access version of the extension that we believe should fix compatibility with the latest versions of Visual Studio. Please give this a try if you can and provide any feedback you notice.

Best Regards,

1 Like