Visual Studio 2008 question

Not sure this is the place to ask but i cannot find an answer. I have got a new pc and reinstalled visual studio 2008 on it and am developing an app for vf50 on ce6 in c#. Everytime i now go to change any of the design it changes most of the designer file so it does not build unless i manually change it back. As far as i can tell all the sdk is installed correctly and the project was set up correctly before.

Any ideas what am i missing?

Did you install the right updates for VS2008 as well? Currently we have SP1 installed.

Hi yes i have checked this and reinstalled the updates. I am still experiencing the issue. I might try installing from scratch.

Would anything from 2013 and compact 2013 interfere?

No, having VS2013 or WEC2013 installed in paralles should not affect the behavior of VS2008, at least we have not seen this on our installations. Did you once analyzed the changes of design files? What changes exactly there?

Things such as = new System.Drawing.Font(“Tahoma”, 12F, System.Drawing.FontStyle.Regular); will change to = new System.Drawing.Font(“Tahoma”, 12F);

lines such as
this.AcceptBtn.TabIndex = 191;
this.AcceptBtn.TabStop = false;
this.InOut.UseVisualStyleBackColor = false;

get added in if not already there.

Also when i open up a project all the form background now show as being black.

@stephen.digi: That somehow does not make any sense… Did you already tried to reinstall VS2008?

I have not tried to reinstall yet as i am having to work on a different project at the moment which does not use 2008. It does not make sense to me either. I was thinking it may be the wrong .net version but as far as i can tell its correct.

It has now got worse. I decided i would use 2015 instead of 2013 on my other project which has worked fine but after installing the application builder for 2015 i now get the following error in 2008. I have uninstalled and reinstalled 2008 and the sdk. Do you know what these registry settings should be? I am using windows 10. the only thing i can find on this is this but did not seem to help http://www.nullify.net/Article/287

Warning 1 An internal error occurred in PlatformVerificationTask. System.Exception: Could not locate an IAsmmetaBindingService for platform WindowsCE. Check your registry settings for the platform.
at Microsoft.CompactFramework.Build.AsmmetaContext…ctor(String ndpversion, String platformFamily, String platformID, ICollection references)
at Microsoft.CompactFramework.Build.Tasks.PlatformVerificationTask.Execute() Control Panel