Virtio rpmsg bus virtio0: msg received with no recipient


I’m correctly generating my image Yocto-hardknott-technexion with this:

$ mkdir tn-imx-yocto
$ cd tn-imx-yocto
$ repo init -u -b hardknott_5.10.y-next -m imx-5.10.52-2.1.0.xml
$ repo sync -j8
$ DISTRO=fsl-imx-x11 MACHINE=pico-imx7 BASEBOARD=pi source -b build-x11-pico-imx7
$ bitbake core-image-base

Then after I run modprobe imx_rpmsg_tty I have issue: virtio_rpmsg_bus virtio0: msg received with no recipient

I tried this: RPMsg error: virtio_rpmsg_bus virtio0: msg received with no recipient

But not solved yet

How to solve?




Hello @neuberfran,
it seems that your problem is being caused by the code that’s running on the M4 side. Please check the firmware you are booting on the M4 and make sure that the destination of the messages is correctly set, just as is described in the solution of the linked thread.

Best regards,
Rafael Beims

@rafael.tx Pls, help-me more.

What exactly could be wrong with the m4 side code?

I cannot really help you debug code that’s maintained by your SOM supplier. In this case I think you are better off asking them for help.
Here at Toradex we always strive to give the best support we can to our customers, and you are welcome to try one of our offerings!

Best regards,
Rafael Beims

@henrique.tx Please help-me
with This and/or tell do IlanFigueiredo to help-me
Because IlanFigueiredo account not accept @ mensages

I suspect the code from the SOM supplier is made to run on older models, or at least that is what it seemed when I worked with iMX7. On line 83 and 102 of the str_echo_freertos.c try changing the “src” to “dst”.

Dear all, I’m closing this topic as this community is exclusive for Toradex-related hardware and software.

Best regards,