VFxx Update Tool changes - How to do a complete backup?

Dear Toradex

In the latest UpdateTool from image version 1.7, it is not possible to do a complete backup of bootloader, Config Block, OS image, Registry etc.
I can either make a backup of the registry, config block or filesystem

Why is this removed? I could this in the previous versions (I need to update from 1.4 to 1.7)

How do I now make the production image? It contain OS image, registry, Confgi block and filesystem changes.

It was much easiere when I just could make a complete backup. Now I need to run a bat file updating image, config block, rwgistry and filesystem seperate!!


Hi @TJO,

Unfortunately for all new SOCs we decided to use the new UpdateLib concept of single sections Backup/Restore. Only PXA and Tegra still use the old concept.

I’m sorry for the inconvenience this might cause you.
You should be still able to fully automate the update procedure with a batch file.

Maybe in future i will re-add the feature by allowing to open a layout file (similar to the one in Tegra) that will automatically process all the sections. Also such a layout file could be generated during Backup of multiple sections.


Ok… Is there any specific order I need to apply the backups? First Filesystem, then config block or does the order not matter?


Hi @TJO,

The order does not matter.

Hi Germano.tx

I tried braking the update procedure into sections in these steps:

1: Updating bootloader
2: Updating CE6 to CE8
3: Update Registrybackup
4: Update Config backup
5: Update Filesystem backup

But it fails with first step. My starting image is CE6 version 1.7

I run this command to update the bootloader: updatetool /u bootloader,raw,eboot.img

This should be according to documentation: /u section,format,path

But I just get a dialog with “update error”

The directory listing is this so the files are there

    Directory of \usb hd\ucm update\master1.7

01/01/06  12:08p                      498646 Registry1.7.ivr
05/01/20  11:49a                    30805547 NK8.BIN
05/01/20  10:57a                    17963751 NK6.BIN
01/01/06  12:51p                       10240 config1.7.cfg
01/01/06  12:45p                    11886235 Filesystem1.7.ivf
01/21/20  06:41p                      102400 UpdateTool_CE8.exe
01/21/20  06:41p                      134144 UpdateTool.exe
05/01/20  10:58a                      262144 EBOOT.IMG
01/01/06  12:57p    <DIR>                    Recovery
03/17/17  08:16a                        1183 programming_script.bat
09/30/20  10:52a                         563 Filesystem.bat
01/01/06  12:23p                         710 Image.bat
09/30/20  10:52a                         553 Registry.bat
09/30/20  10:52a                         557 Config.bat

Dear @TJO ,

Windows CE does not have the concept of “current directory” as in Desktop Windows, so paths are always absolute. You need to specify the whole path in the command line:

updatetool /u bootloader,raw,\usb hd\ucm update\master1.7\eboot.img

the same of course also for the other sections


It depends on the CE version in the module before update.

If I flash the modules with CE6 version 1.4 and it is update to CE8 version 1.7, it must be restarted before I can load the file system backup to it. Else I get an unspecified error from update tool


Hi @TJO,

OK, this is probably a special case as we did some major changes from 1.4 to 1.5 in the NAND FileSystem handling. I did not think you’ll downgrade to a very old version.
Please also check the release notes, as lots of things were changed and bugs were fixed since 1.4, maybe some will affect you. Especially the new Flash handling improved reliability of the flash device.

Hi Germano

I did the downgrade, because we have some old units out there with 1.4 on them. And in the case we do an upgrade of those (for any reason) it would be nice to know that the automatic update procedure also would work on them. Thats why I did the test with the old version…

The new module we get in production is version 1.2B, so we need to upgrade the image for the future