VF61 recovery mode u-boot bootloader won't run

I just received a shipment of 100 VF61 modules. They come from the factory with Windows CE, but I need to run Linux. I plug the VF61 into the Colibri Evaluation board and run a TeraTerm script file on a connected Windows 10 computer to automatically update the boot loader, flash the Linux OS, and load all of my application code. This works very well. I was loading my software (u-boot, Linux and application code) on a group of 29 VF61 modules. 28 of them worked perfectly, but one failed. I investigated the failed VF61, and it appeared to have no boot loader. Powering up the module with TeraTerm connected to the evaluation board (set at the usual 115200 baud, no flow control) results in nothing being displayed on the terminal.

I attempted to recover the module using the instructions here: VFxx Recovery Mode | Toradex Developer Center

First I discovered that the imx_uart.exe program will NOT work on Windows 10! It gives an access denied error when trying to open the COM port. So I used an old Windows XP machine. The recovery appeared to work. I got the following output:
config file <.\vybrid_uboot.conf>
parse .\vybrid_uboot.conf
starting associating phase
association phase succeeded, response was 0x23454523
HAB security state: development mode (0x56787856)
== work item
filename u-boot-nand.imx
load_size 0 bytes
load_addr 0x13f00000
dcd 0
clear_dcd 0
plug 0
jump_mode 2
jump_addr 0x00000000
== end work item

loading binary file(u-boot-nand.imx) to 3f4074e8, skip=0, fsize=6eb18 type=aa

<<<453400, 453400 bytes>>>
succeeded (status 0x88888888)
jumping to 0x3f4078e8

But when I connected TeraTerm and power cycled the board I still got nothing on the terminal. It appears the u-boot boot loader is still not running.

If I connect TeraTerm after the recovery operation, but before power cycling, I get the following each time I hit Enter:
Colibri VFxx #

But after power cycling I get nothing. Help! How do I recover this VF61 module? Can it be recovered? Or do I need to contact sales and return it for a replacement?

each time I hit Enter: Colibri VFxx #

This indicates U-Boot loaded to RAM is working. You need to flash bootloader to NAND before cycling power. On page you provided please follow the “Flashing Embedded Linux…” and then “flashing from scratch”.

Actually the imx_uart.exe program works OK under Win 10. The open() failed: Permission denied message usually means that some other program holding selected COM port.

That program load boot loader to RAM so it’s expected that it gone after power cycling. So after U_Boot loading you should run terminal program on your dev machine and run commands described here.

After following the instructions “Flashing Embedded Linux” and “Flashing from Scratch” the VF61 module has been successfully recovered. It boots Linux and runs my application, although I still don’t know what made it loose the boot loader in the first place.

No, the imx_uart.exe program will NOT run under Windows 10. It gives the open() failed: Permission denied error even when no other application has the specified COM port open. It also gives the error regardless of whether the cmd prompt window is being run in administrator mode or not.

I’ve tested it under Windows 10 on 3 machines. And it works o all of them. Can share a video.

What is your COM port number? The imx_uart utility can’t use COM ports higher then COM9 with the commonly known syntax.