VF61 Qt Cross compile there isn't any qt library in the target device

down vote
last week I recieved my brand new Colibri VF61 with the Aster carrier board from Toradex. I followed Toradex’s guide on how to prepare the board to cross compile with qt here.

Everything from the tuturial went perfect, however I tried deploying my app and everything goes fine until I open the executable on my target device because I get the following message :

error while loading shared libraries: libQt5PrintSupport.so.5: cannot open shared object file: No such file or directory
I went to see if I had any Qt files in my target device at all, and there weren’t so I went to my sysroot folder in my host device and I copied all the Qt files to my target device, (Qt5PrintSupport was there) but after I copied all the files in the exact same location as they where in my sysroot the same error keep appearing.

The files I copied were:

LibIcal Qt5Core Qt5OpenGLExtensions
Qt5Svg PulseAudio Qt5DBus
Qt5Positioning Qt5SystemInfo Qt5
Qt5Declarative Qt5PrintSupport Qt5Test
Qt53DCore Qt5Designer
Qt5PublishSubscribe Qt5UiPlugin
Qt53DExtras Qt5Enginio Qt5Qml
Qt5UiTools Qt53DInput Qt5Gui Qt5Quick
Qt5WebChannel Qt53DLogic Qt5Help
Qt5QuickTest Qt5WebKit Qt53DQuick
Qt5LinguistTools Qt5QuickWidgets
Qt5WebKitWidgets Qt53DQuickExtras
Qt5Location Qt5Script Qt5WebSockets
Qt53DQuickInput Qt5Multimedia
Qt5ScriptTools Qt5Widgets
Qt53DQuickRender Qt5MultimediaWidgets
Qt5Sensors Qt5X11Extras Qt53DRender
Qt5Network Qt5SerialPort Qt5Xml
Qt5Bluetooth Qt5Nfc
Qt5ServiceFramework Qt5XmlPatterns
Qt5Concurrent Qt5OpenGL Qt5Sql libxml2

Inside /usr/lib/cmake


imports libexec mkspecs plugins qml

folders to /usr/lib/qt5

I have noticed that the problem may be that I dont have the “lib” folder inside /usr/lib/qt5 however I don’t know how to create it since it wasn’t in my sysroot.

Summing up: I want to execute my app by cross compiling but the lib folder is missing and I don’t know how to create it or link it.

You forgot about building/deploying the target image for Qt as explained in the following article on our developer website.

Hi, actually I did that I used

bitbake -k console-tdx-image

Which prvodided me the image but unfortunately, the image didn’t had anything related to Qt on it

Update, thanks to your comment I figured out I might have not erased the cache after changing local.conf file to add the qt layer, so the qt layer isn’t added at all. I’ll post the answer if everything goes just right.